Unable to create nuget package using UiRobot.exe

I am trying to create a nuget package using UiRobot.exe but getting following error.

Opening "C:\Users\<project-name>Main.xaml" is not supported.

The command I am using is

 .\UiRobot.exe -pack <path-to-xaml_or_json> -o <path-to-package-folder>

I tried enabling low level logs and checked the generated logs in Event Viewer but they are not of great help. The only thing I am seeing is

<ProcessingErrorData>
  <ErrorCode>15003</ErrorCode> 
  <DataItemName /> 
  <EventPayload>1F293C1BE33FDE40A4D848001248F19F01000000433A5C44524445454339393632345C5F776F726B5C345C735C4F75747075745C62696E5C52656C656173655C4368726F6D654E61746976654D6573736167696E672E70646200</EventPayload> 
  </ProcessingErrorData>

I am able to execute the process using -file option for the same package.

After reading through few suggestions on the forum, I tried disabling anti-virus as well but no luck with it as well.

Would appreciate any pointers to fix this issue.

Hi @adityamooley

Welcome to our UiPath Forum! :slight_smile:

I believe you have already tried to specify the project.json in the command instead of the Main.xaml file?

Yup, you guessed it right. Already tried using project.json but getting the same error. :frowning_face:

Hi @adityamooley,
Maybe stupid question but have you tried to open CMD as an Administrator? No matter if you are already admin. Try just open it using “open as an administrator”.

Hi Pablito,

Yes I tried running it as both admin and non-admin. And to add to this, I ran it on Powershell instead of cmd. I hope that won’t be causing any issue.

Interesting. Just to be sure, I’ve tested it myself on 2019.5 and it worked without any issue. Could you say which version of Studio and Robot are you using?

For reference, this is the exact command I’ve used that worked:
C:\Users\Maciej\AppData\Local\UiPath\app-19.5.0>UiRobot.exe -pack "C:\Users\Maciej\Desktop\ProjectName\project.json" -o "C:\Users\Maciej\Documents\UiPath\Packages"

I’ve also run it from the CMD as an Admin, so please also try that.

Please use CMD. Please also remind that you need to indicate whole path including json fine at the and otherwise it will get the error you have:


Additionally please remind that destination folder/path where package will be saved must be created manually otherwise you will catch this error:

If everything will be made correctly you should have information like this:


image

@loginerror @Pablito

Thank you guys for your suggestions. I must admit that I had not created the packages folder before running the command as I was expecting the folder to get created automatically. But other than this I had done everything you guys have suggested here but nothing worked.

On further debugging, I realized that today I have a new version 19.5.0-beta0060 and when I ran the same command using this version of UiRobot.exe, the package got created successfully irrespective of it being Powershell or CMD, admin or non-admin.

When I logged this issue, the version I had was app-19.5.0-beta0024 and using UiRobot.exe in this version is still giving the same error.

Really appreciate quick responses from both of you on this issue. You guys Rock!!!

1 Like

@loginerror Is there any way to add release notes to the pack command?

1 Like

As far as our documentation can tell you, this is currently not supported:

I added your question as an insight for our team to consider for the future though, who knows :slight_smile:

1 Like

Hi @loginerror, the command line documentation doesn’t mention a way to pack “Tests” in order to publish them in orchestrator.
We can pack them from Studio and the only difference observed inside the nupgk is in project.json :

  • outputType" changes from “Process” to “Tests”.
  • the object “arguments” is included

Changing outputType from “Process” to “Tests” produces an error : “opening project.json is not supported”.

Is there some hidden options ?

Studio Pro 2020.4.1 Enterprise