Unable to create a robot in a new tenant

Hi, I am trying to deploy a package into a new tenant. Unfortunately, to create the robot, I cannot find the ‘add robot’ button in my orchestrator page. I also had accidentally deleted the default tenant prior to creating this tenant

Hi @SreyaSalil
Well you don’t really need to create robot by yourself. Just create a new machine and provision it with your PC. The machine name should be the same as your system name.
After your machine is created, open Uipath Assistant and Go to Prefrences => Orchestrator settings and there you will find “connection type”. select it as “Service URL” and enter your orchestrator URL e.g. “cloud.uipath.com/org_name/tenant_name”. and click Connect.

Your robot will be connected and you’ll see your robot in the robot section on orchestrator.
Let me know if you still face the issue.

Hi @raheelferoze
I tried what you had suggested me to do. But, I am still unable to find any robots in the robot section on orchestrator. Also, the robot tray says “Unlicensed”.
Screenshot 2021-04-17 120843

@SreyaSalil is it possible for you to update your assistant and studio ?
After you update your assistant you’ll see an option in Orchestrator settings as “Connection type” from where you can select “Service URL” and then connect. It’ll probably fix the issue.

Let me know if it still doesn’t fix the issue
Regards,
Raheel Ahmed

Hi @SreyaSalil

Welcome to UiPath Forum.

Try the below steps to create the robot and connect with studio.

  1. Open UiPath Assistant
  2. Go to Orchestrator settings in Assistant app.
  3. Make connection type as ‘Service URL’.
  4. Copy the URL from orchestrator website.
    (Eg: https://cloud.uipath.com/*****/*******/orchestrator_/)
  5. Past the copied URL under Orchestrator URL option in Assistant app.
  6. Then give Sign in.

This will create the robot and machine automatically and connect the robot with studio.

Feel free to reach us at any time if you have doubts. Thanks.

Happy Automation

On step 3 you made a lil mistake.
The option he/she should go for is *Service URL not “service key”.

Thanks,
Raheel Ahmed

1 Like

Thanks for correcting me @raheelferoze