Unable to Complete Level 3 Assignment1

Hi,

I trying to figure out the issue with the attached Project. After running the Project it goes infinite loops and keeps on opening “SHA1” and “ACME System1” page.
After debugging the Project also I am unable to resolve the Problem.


Please let me know what needs to be updated.
Thanks and Regards,
Vineet

Hi @VineetArora

Welcome to the community!!!

Well it seems like the code is looking for a specific key in the config dictionary and it is not available in the config. That’s what the error say. Make sure you have specified all references to values in config accurately. In the code the reference of the key should be exactly the same as the text you have in the name column of the config file. Once those errors are fixed it should work fine. The other concern you have here on robot trying to execute the open application again and again is also because of the same error. It tries to resolve it by retrying the same set of tasks.

2 Likes

Hi Lahiru,

Thanks a ton for the Support… Yes, there was a Typo. Now its working fine.

Need one additional Support.
I got the below error as all Transactions were complete. Is this expected as part of the Assignment? Or do i need to add an exit condition?

Regards,
Vineet

Hi @VineetArora

It is not expected :slight_smile:

Can you show me the condition you have included in that if condition you have there in the screenshot?

It should be something like

In_transactionNumber < YourDT.Rows.Count

2 Likes

Hi,
Yup, I was able to fix it and submit the assignment.

Issue was “In_transactionNumber < = YourDT.Rows.Count”.
After updating it to “In_transactionNumber < YourDT.Rows.Count” as suggested by you the issue was resolved.

Thanks and regards,
Vineet

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.