Unable to Click on Save button

I am trying to download a file from Tabula. After clicking on “Export” a new notification bar opens and I want UiPath to select “Save”.

UiPath is unable to detect the Save button everytime. I have tried using “click image” and “Delay” activities It doesn’t work. Please help!

Hello @sadiaafrin
Use “click” instead of click image
First click on that drop down ,and then save

1 Like

@iVishalNayak I tried using click and when it didn’t work, I used click image. I don’t really need to access the drop down. Only clicking on Save would work.

1 Like

Send me , let me give it a try

Use two click activities,
First click to select dropdown and Second click to select “Save As”.

1 Like

You can do it one selector but you should have the proper knowledge of selectors, which you will find in Ui-Explorer of that activity.

1 Like

@iVishalNayak Thanks! it’s a long sequence. What should I send you?

Just those …which includes “save” part (or till that)…what i will be doing is i will just try that click activity on that save…So just send that part…or tell me how …I will try

@iVishalNayak hey Thanks again. Just try to download a csv file using Internet explore. when the notification bar comes up like the picture I have attached in my post, try clicking on save That’s it.

1 Like


See I am able to save …here is the file…I get different Box for saving I am able to click on save and it gets saved…Its better you send me the site which gives that particular notification barSequence3.xaml (7.7 KB)

did SIMULATE CLICK property is enabled in CLICK activity
Cheers @sadiaafrin

1 Like

Or you can use Chrome browser :smile:

Hello, Thank you all. I tried clicking on the dropdown and then hotkeys (enter). It’s working fine now. I just need one advice. In case of situations like this (the attached picture) where the region goes outside the button, should I use click image?

Screenshot (3)


Normal click works fine right?

thats not a problem, as it is a UI Element region for that element only
the click itself will work buddy

@Palaniyappan It didn’t work for me in some cases so I thought maybe it’s because of the outer region. The problem might be somewhere else then.

@iVishalNayak in some cases it doesn’t work as I am working on dynamic files. Thank you.

1 Like

were we able to select the inner region of that image or the wordings in that image as a element
if so then we can replace the aaname attribute with wild card *


I have the same problem with a save button after I sent the Ctrl P command to the web page. I am trying to use the print to PDF and save that file to a network share.
Ui path save as button
The click function and the click image function both fail to click the save button and present the save location screen.


1 Like