Unable to click on a Web page menu option

studio
recording

#1

Help!! I’m simply trying to select a menu item on a Web page but whatever I try, I just get a “selector not found” error. It’s such a simple and fundamental requirement, I’m anxious to understand what the problem is and how to work around it. Screenshots of the Web page, sequence and UiPath Explorer are in the attachment.

AJ


#2

Could be a dynamic selector. No attachment in your post.


#3

I’m pretty sure it’s not a dynamic selector.

I’ve attached the screenshots this time!
Selector Not Found Issue.pdf (847.3 KB)


#4

Hi Alan,

From your attachment i can see that the error is because of Attach Browser activity(<< Source: Attach Browser ‘Transacti Page’ >>) but you provided us selector details from the Click activity. Which browser are you using?

Also, could you please paste here the selector from Attach Browser?
It should look like this: < html app=‘chrome.exe’ title='Unable to click on a Web page menu option - Rookies - UiPath Co’ />*


#5

The selector from the “Attach Browser ‘Transacti Page’” activity is:

html app=‘chrome.exe’ htmlwindowname=‘bib’ title=‘Transactions: HSBC Bank UK’ /


#6

I have tried the recorder on the same webpage, therefore i have the same selector and it runs just fine. The only time that error occured was after i closed the browser window(Chrome) and ran the workflow again. I also want to mention that i have Studio Community Edition 2017.1.6435

Do you have the page on the main screen when you run your Recording Sequence?


#7

you can use click text activity


#8

@b4bbler could you find the solution, I have similar issue


#9

I did overcome one selector problem by editing the selector that UiPath Explorer offered (it had not discovered the full variability of a reference number in the selector, which changed on every page refresh). I was advised to capture the same selector a number of times and paste them into Notepad for comparison, and then further adjust the selector offered by UiPath Explorer. This worked :slight_smile:

Perhaps the following will indicate how subtle selector selection can be. On this Web page pane…

I want to scrape the date (19-Sep-2017), and the balance (4,666.12), which, of course, are both dynamic.

UiPath Explorer suggests:

        webctrl aaname='*2017' parentid='loaded' idx='1' 

This captures the date correctly, but it will fall over in a few months, of course.

Changing the selector to:

        webctrl aaname='*' parentid='loaded' idx='1'

returns “1127”, which means it must be coming from some other part of the Web page (it’s actually an internal reference number: “company ID”). But using:

        webctrl aaname='??-???-????' parentid='loaded' idx='1' 

correctly returns the date :slight_smile: .

Similarly, recording the sequence for the balance value, as you would expect, identifies the selector as:

         webctrl aaname='4,666.12' parentid='loaded' tag='DIV'

Replacing the dynamic value with a placeholder:

          webctrl aaname='*' parentid='loaded' tag='DIV' 

Returns a title “Bank Accounts” from the Web page (not the balance value required), which turns out to have the selector:

          webctrl aaname='Bank Accounts' parentid='loaded' tag='DIV' 

Using the following selector works :):

          webctrl aaname='*.??' parentid='loaded' tag='DIV' 

In this situation, where a selector wildcard matches a selector preceding the one required, is there a way of asking for the second (or nth) instance of a wildcard selector, for example, rather than relying on some embedded character(s) in the string required (which might not always be available)?

AJ