Unable to click a button in Firefox. UIPath unable to find it at all

I have been trying to build a RPA to go through my emails in Firefox, and sort them accordingly. I have built most of the process now. The step I am stuck on is trying to click the delete button. No matter what I do it is unable to find it.

Yes I have Firefox extension installed, plus I have tried the using image and different selectors.

When I select the button.
“The Indicated Element does not belong to the browser/application”.

What causes this, is there a better browser focused RPA, why cant I simply click on a button that clearly exists.

Are other elements captures successfully?

@Carson_Skjerdal

Welcome to Forums

If you are working on emails the why don’t you use outlook / SMTP activities, this will not require any Ui Interaction, and very easy to manipulate the emails

Hope this helps

Thanks

1 Like

@ksrinu070184 I have been debating that. I just figured that a lot of my work is browser based, and would be best to focus on a browser based approach first. Though looking at UIPath alternatives, nobody really seems Browser focused, which might be for a good reason.

@ImPratham45 Yes so far every other element I tried works.

I click on the navigation bar, type in a new address, click the navigation button, Pass through two login buttons, Click on an email, Obtain the title of the email. then I have a switch statement based on the title.
This is where the delete button is un-selectable.


Perhaps for the time being SMPT is just the best way to go.

If you can say what is the web page you are trying this (if it is public) we can try to help, this button will always have some way to be clicked…

@bcorrea - It is in my RoundCube Webmail, or https://cs17.uhcloud.com.

Sorry but that is a private link that we cannot go to… maybe you can share some prints…

Sorry I knew it was private, I was hoping someone was familiar with the mail platform. Got a bit busy this week bcorrea but I’ll take a dive with some SMTP solutions and come back to this.