Unable to capture row count value as 0 if no record is able to filter from Excel

Hi everyone, I have encountered issue where I filtered the columns “Colour Code” which is not “GREEN” and “Machine Model” that contains “Saturn HD Feeder (K-2)HGST #105”. In Excel, as seen in the screenshot, it was unable to filter due to no records are able to filter for the machine model I want. And then it captures the entire data row count which is incorrect, the correct output should be 0. Currently my configuration also has another issue, where the bot is not sure how many rows are there after filtered and copied to another sheet, and then it detects my row count as 34999 which is incorrect. I would like to seek some assistance to resolve the issues and not sure what went wrong. I have also attached the files for reference. Thanks.




Excel_RPA.zip (9.5 KB)

@dvkc91

  1. Are you applying filter on excel and then readingb?
  2. Can you read whole data and then filter using filter datatable …that way the data manipulations would be easy
  3. If you want to filter on excel only…then you need to read the visisble rows only and not all
  4. If filtering on excel…are you using excel filter activities?

Cheers

Yes, I did use the Excel filter activities. I have filter by Color Code and also Machine Model as mentioned earlier. But in this case, what if my Machine Model that I filtered is unable to filter from Excel, how does the bot know that there is no record to filter and set row count to 0? As I need to update this value write to an another Excel cell specifically.

@dvkc91

Then better read and use filter datatable…that way it would be easy

Cheers