Unable to automate the Excel Sample Task

Hello all,
While I am trying to perform the Excel Automation I am facing the issue which says Library not registered.
I reinstalled the UI Path Studio X and also installed the plugins for of the Excel automation.
Also reinstalled the Office 2013.

I have referred the thread having the same issue and tried the steps suggested in that, its not working.
Please suggest what to do.

!
Due to limitation I am unable to attach the second image but it says Error opening workbook. Make sure Excel is installed.

3 Likes

Can you post screenshot of your xaml here! Please. :smiley:

Thanks.

cheers :smiley:

Happy learning :smiley:

1 Like

Here is the output of the Xaml File. @pattyricarte


<TextExpression.NamespacesForImplementation>
<sco:Collection x:TypeArguments=“x:String”>
<x:String>System.Activities</x:String>
<x:String>System.Activities.Statements</x:String>
<x:String>System.Activities.Expressions</x:String>
<x:String>System.Activities.Validation</x:String>
<x:String>System.Activities.XamlIntegration</x:String>
<x:String>Microsoft.VisualBasic</x:String>
<x:String>Microsoft.VisualBasic.Activities</x:String>
<x:String>System</x:String>
<x:String>System.Collections</x:String>
<x:String>System.Collections.Generic</x:String>
<x:String>System.Data</x:String>
<x:String>System.Diagnostics</x:String>
<x:String>System.Drawing</x:String>
<x:String>System.IO</x:String>
<x:String>System.Linq</x:String>
<x:String>System.Net.Mail</x:String>
<x:String>System.Xml</x:String>
<x:String>System.Xml.Linq</x:String>
<x:String>UiPath.Core</x:String>
<x:String>UiPath.Core.Activities</x:String>
<x:String>System.Windows.Markup</x:String>
</sco:Collection>
</TextExpression.NamespacesForImplementation>
<TextExpression.ReferencesForImplementation>
<sco:Collection x:TypeArguments=“AssemblyReference”>
System.Activities
Microsoft.VisualBasic
mscorlib
System.Data
System
System.Drawing
System.Core
System.Xml
System.Xml.Linq
PresentationFramework
WindowsBase
PresentationCore
System.Xaml
UiPath.System.Activities
UiPath.UiAutomation.Activities
</sco:Collection>
</TextExpression.ReferencesForImplementation>

I am having the exact same problem on a fresh machine with the addin installed and listed in Excel 2013, while following the academy tutorials.

Hello,

I would like to ask you a few details that would help us determine what went wrong and of course maybe provide a solution to your problem :

  • What operating system are you using
  • What version of StudioX are you using
  • Also can you send us the logs (%localappdata%\UiPath\Logs) we would really appreciate it if you would clean the files there and reproduce the issue before sending them :slight_smile:

Regards,
Dragos.

1 Like

@dragos.suma Answer to your questions are as follows:-
OS - Windows 10 Professional Version 64 Bit
StudioX Version :- Studio 2019.11.0-beta.2 Community Edition
Logs.zip (5.3 KB)

Find the attached logs for the reference.

1 Like

Hi. I do have the same issue as what @G00119 specified. I’m looking for the answers here but the thread ended on Dec 2019.

Maybe you can use the other method the “Custom Input” rather than using “Indicate in excel”. I’ve tried and it’s working perfectly.

I also have the same problem; somehow it keeps indicating the workbook does not exist but I am very sure it is there. Tried moving the excel file to desktop, also hit the problem. Looking forward to a resolution.

Hi @leechengn I believed you are following the steps provided in the video in Workbook titled as RPA Starter. You can use the other method the “Custom Input” rather than using “Indicate in" then your program will run perfectly. I think the “Indicate In” command is not working well in our trial version.

Hello,

Could you please follow the following guide and please come back with the results.

UiPath Excel Addin Installation Troubleshooting v4.docx (388.6 KB)

Regarding logs, they are usually found in %localappdata%/UiPath/Logs and

  • Studio.log – gives us information on how the Studio started or if it was able to load all the correct libs.
  • Execution.log – gives us information on what happens after you click the run button
  • UiPath.ExcelAddIn.log – gives us information on how the plugin interacted with Excel ( will not be present if the Add-In failed to install )
  • ExcelAddIn_Install.log – gives us information on the issues encountered during the Excel plugin installation ( in this particular case it’s the most important )

Usually we would request that you delete the logs prior replicating the encountered defect. This is a best practice when reporting a defect since it would speed up the reading of the logs by the development team.

Regards,
Dragos.

Latest video to fetch record from excel its latest technic you must watch if you are working in excel automation please visit

So @Aleem_Khan please educate me how does this video relates to StudioX ?