Unable to attach window with selectors

selector
uiautomation
studio

#1

I have an authenticator app like below

and I’m trying to attach the window with below selectors

"<wnd app='applicationframehost.exe' appid='*.AuthenticatorforWindows*' title='Authenticator for Windows' />"

below are the selectors available for the app.

Attach window activity fails to find the selector of the app. Any leads on this issue will be greatly appreciated.

Please note: the app is an authentication tool from microsoft store.


#2

Hi

I played a bit with the app but I didn’t notice any changes that would imply using wildcards. Is there a specific reason you are using wildcards?

I have used the following selector and it attaches every time.

wnd app=‘applicationframehost.exe’ appid=‘56672RoelvandeWater.AuthenticatorforWindows_0c9a7a0hg7q6r!App’ title=‘Authenticator for Windows’ cls=‘ApplicationFrameWindow’ />

Bogdan


#3

I wasn’t sure if the selectors will change. Will try it anyway. Thanks. :slight_smile:


#4

I had an issue with direct Excel automation were the selector changed when Excel was in full screen mode. Maybe check in UI Path Explorer if the selector changes in full screen.


#5

Tried it, but the selector seems static whatever you do to the app.


#6

If you notice any changes in the selector you have to somehow find the pattern and then use a dynamic selector. Good luck! :slight_smile:


#7

Tried Attach window along with Activate activity. Worked like charm. Much thanks :slight_smile: