Unable to add system.directoryservices namespace in studio

HI Folks,
I am unable to add System.DirectoryServices namespace in studio i have added the dll in C:\Users\chand\AppData\Local\UiPath\app-18.4.1

I am unable to find the namespace in imports section

@chandravegi the Directory class already available into studio out of the box. Try call his functions directly into assign activity.

I am sorry I am looking this namespace

Thanks for your reply but yeah Iam looking System.DirectoryServices this namspace to validate LDAP credentials check from active directory

Ok. Have you tried this?

import namespaces

@Fabiano_Torres tried it and am not finding even from imports section

Hi @chandravegi

Try this method:

Thanks a lot


The mentioned solution to update the xaml file in notepad is not working.
I have added System.DirectoryServices in the assembly part of the xaml, but when I open the xaml in studio it throwing error as System.DirectoryServices can not be resolved.

Hi @sarathi125

What Studio version is it?