UIStudio Activation Fails with 2016 version


We have an old version of UIPath installed on an AWS Windows Box (2016.2.6402 version). And we occasionally use it to manually execute a workflow once in a while.

First, I noticed today that the activation is failing. Before it would go through the auto renewal and work seamlessly.

So I deleted the License folder and tried to go through the process from scratch hoping to fix it.

Now, I open the program > Get Free License > Add my email > and get the same error as before:

Activation failed with error: 0
Error description: No Error
License status: Server License Expired

Device ID: Xeu633V04U46SlfzpKPb
User Name: Administrator

uipath activation screen|558x406
uipath activation failed|564x405

Second question, how do I get the email updated in the UIPath system. I am using the same the old email that worked and still getting the activation error. But I’d like to update it separately.

Third, can I associate a community license with old version of UIStudio
I did create a new UIPath account for the UICloud and such. It has zero seats used in all categories. It seems like there isn’t a way to associate the old version of studio I am using with this new account so that I can pull a license from a UIPath account?

It seems the xaml files we have created to manually run workflows are not compatible with the new version of studio. That is why we simply can’t upgrade and use the new licensing. We get a lot of errors and it seems we’ll have to create the whole workflow from scratch which isn’t practical. Any tips for a migration? Or some way you can make an old license active for legacy customers like me?!

Thanks for the help!

The main problem. Your license is expired. Contact Uipath Tech support to renew it. They can then release the current ID, so you can install a new version and activate it again.

Your license is expired. See First.

No you can’t. You don’t activate a community edition by entering a license. It just gets activated. It will update automaticly when new software is out. (In fact the CE edition is the test software for Uipath, what better ways are there to let your software test by live users ;).
You can’t switch between the versions.

You can get the installers from platform.uipath.com but you cannot activate by using the old license > See First.

That can happen. The core files and activities are updated.

What are your options?

  1. contact Uipath tech support and renew your license so you can activate your 2016 version again. (if that is even possible, not sure about that).

  2. Contact Uipath Tech support and let them release your current (expired) activation so your device ID is free again. Install a new studio and activate (you still need to renew your license to the 2019 version).

  3. install the community edition. Import your project and see where the problem starts. You can repair your project and dependencies and you might have to test your workflow again. But make sure to test with a copy of your project. Uipath 2019 projects are not backwards compatible with previous versions.

so in the first place, i would ask Uipath tech support and tell them your problem.

@jvanmarion thank you for your reply!

I have emailed them just now but they do generally ask not to email for community edition issues but post here instead. So wondering if it’ll just get nowhere :frowning:

Does their support staff hang out here that we can ask?

In your post you were talking about a Licensed version, but it had expired, so that’s why i pointed you to the tech support.
check this url about the life-cycle of Uipath. https://www.uipath.com/product-lifecycle
It has ended some time ago for the 2016 version.

You can give this one a try. if you had a license key/file.

So the main question. What do you want?

  • Renew your license with a new (paid) subscription?
  • Use the community edition?

Be aware that with an update on the CE (Community Edition) your process could not work anymore. That’s the downside of an CE version.

You have to rebuild your project anyway. It just became to old and isn’t supported anymore. So the above 2 questions are the main concern :wink:

@loginerror, are there any other options for @theuser311 to let Uipath remove his DeviceID ?

I didn’t communicate properly then. We were always on the free/community version.

Apparently I can’t email technical support without a license version so that form to contact support doesn’t even submit.

And I am on the free version so I don’t think I ever had a license file, unless it’s hiding somewhere I don’t know. AppData\Local\UiPath\License has a uuid.cache, uuid.lic and uuid.sinfo. None of these validated at that activate link or the contact support form. The only license info I found was NALPNA, probably a code for free version…

Ok. no probs,
hopefully loginError can point you in the correct direction. i have no solution for this.

Hi @theuser311

Welcome to our UiPath Forum! :slight_smile:

A few things, starting with the fact that it would be best to work on the latest Community Edition. Let me address this first:

The new versions work a little bit differently, in the fact that the dependencies are now associated with the particular project and not with your entire machine/environment.

This means that you need a project.json file that lists all the required dependencies for your project. Whenever you open a XAML file in the new version, a new project.json file will be created. Naturally, it will not contain the actual dependencies that you need.

To fix it, you should go to the package manager in Studio and install packages that you used in your old projects.

I believe that is the best way to handle it, as the forward compatibility should be kept. It should be possible to open an old project in the new version :slight_smile:

As far as the licensing, there were some changes to the licensing servers along the way and something might have become deprecated. I’m sure @ovi will be able to answer the remaining questions.

Hi @theuser311

If you are on a free version, then you should be on the latest version (19.10 for now). Community Edition upgrades automatically (that’s why it’s free).

Also, starting with 19.4 version we changed our licensing solution and this is reflected also in the Community Edition: no need for an email, no need for a license key, only online activation.

Only Enterprise accounts still have support for 2016.2 version, but even for these the support will end in March.

Thanks for letting us know – we will try these debugging steps and see if we can fix our flow. The info is much appreciated!

With regards to the second issue: If we use the 2016.2 Enterprise version, will it still work locally if we have the program installed already? Even beyond March? (i.e. it is simply that you will no longer officially support or patch bugs there)