UiRobot stopped working [highly urgent] really need help

If it was updated just make sure you have the excel activities installed.

by excel pack i mean the package version from Studio
also, what`s the range you are trying to read, from the document

Can you share us the XAML r a screenshot of the error???

Hi,

The package version is 2.0.6333.17728. I am trying to read the all document - the range might change with time.

Attached you can find the log file and a screenshot of the errorLog.html (253.2 KB)
.

Thank you for your help.

1 Like

Hello, are you using the read range within an excel scope or the excel system read range?

The target Element was not specified for this activity. You should set its Target property or use this activity inside of a scope activity (Attach Browser, Open Browser, Open Application, Attach Window, Get Active Window, Element Scope activities)

regards.

First sheet or second? I did some read range tests on your doc and they
worked, i didn’t try with the whole document though. Please let me know if
you have the same error if you try with a smaller range

Also i need to know what activity you are using, is it workbook? If you run a simple wf that does only the read, do you still have the crash? I m not sure that the read is the issue here, maybe something breaks after or before.

Sorry about that.

It happens in the second sheet. The first one is just a cover of the document.

I tried both solutions read range within a Excel aplication scope and read range as workbook function.

Thanks,

João Ladeiras

Yeah, please share you XAML for better help.

regards-.

This is supposed to be executed withing 12 documents and only happens in one of them.

If I start on the second document ir works just fine.

thanks

Can you monitor the memory consumption of the robot? Do you see it rising too much?

@Jladeiras - Can you manual open that document in same system where robot is running, and make sure that you’re not getting any popup/error while opening that document.

I had faced one issue, when some plugin / add-on was not enabled in excel

I did not monitor the consumption of the robot, how can I do it?

Manually I can open the file and work on it. The other files that the robot is working on are similar to this one, however with less data.

Added as a defect, will be fixed in a future excel package release.
Meanwhile, try to use a smaller read range if possible.

Hi Gabriel, do you guys have any update on this Excel Package release yet? We are experiencing the same issue in a POC for a key account client (One of Forbes Top 3 Banks) and really wish this could be resolved ASAP so they will purchase the tool.

Let me know if you could help.

Update to latest excel package and try again.

Is this still an issue? I have Studio 2017.1.6435 and am using all the most updated packages, but whenever I try to use the read range activity I get an error that the UiPath Robot has stopped working.

I am only reading a range containing 2 cells (B1:B2). It works fine if I put it in an excel application scope, but that is slightly slower and would require having excel installed.

Is there any special text in those cells? Maybe a format of some sort, hyperlink etc?
What file type is that?

Hi Gabriel

Even i am facing the same issue , when i try to read particular excel using Read range activity in excel workbook , in this case Uipath is not responding.