UiRobot Not using UiPath.Settings file

We have deployed a standalone attended UiPath bot, which is not connected to orchestrator. We currently publish from our studio servers and move the NuGet package into the %PorgramData%\UiPath\Packages folder, where they then appear in the robot tray for install/update, and they can be run from there - all good so far.

What we would like however is for the Robot to take the NuGet packages from a different location, i.e. a shared location which the studio bots are publishing into, therefore making the publishing/updating loop as automated as possible.

I know that in order to do this you should change the “NuGetServerURL” perimeter in the UiPath.SETTINGS file in %ProgramData%\UiPath. So i did this, but after restarting the bot service, there was no change to the behaviour of the robot, it was still looking for packages in the %ProgramData%\UiPath\Packages folder, despite there being a different file path in the “NuGetServerURL” parameter in the SETTINGS file.

Even more mysterious is that after doing some playing around, I’m almost 100% certain that the robot is not looking at that settings file at all, because renaming or removing it does not affect the bot behaviours at all, it still sees that packages from the %ProgramData%\UiPath\Packages folder every time.

Anyone seen anything like this before?

HI Folk,

As per my understanding you have changed the path in NuGetServerUrl in Uipath.settings to any “XYZ” location. now you want your bot to use package from that location.

so my suggestion is to try giving full path and check if you can publish to that location. because the above problem can occurred only if the “XYZ” location is inaccessible due to any reason including folder security.

Hope the issue resolves.

Hi @hk803592, unfortunately I have put the full path into the “NuGetServerURL” property, and its still not working, and I have studio bots happily publishing into the same folder so i know UiPath in general has the ability to access it, and the user account itself has full access too.

The real mystery is that the robot doesn’t seem to even be reading the settings file at all, as renaming or moving it does not affect the robot behaviour…

Hi @Djh,

You mentioned using a Shared location being used; Can you login into the robot machine with the user account that is used for running the bot and verify if the Shared drive is accessible?

Regards,
PD

Hi @PD2, yes the robot server can access the shared location, as right now I’m opening that folder and dragging the NuGet files into the %programdata%\uipath\packages for the robot to pick them up. I just want to exclude having to do this step.

@ovi - do you guys know anything about this? Is there any circumstance where an attended bot, not connected to orchestrator, is not reading from the UiPath.settings file in %ProgramData%\uipath? I’m convinced it may be getting the information from somewhere else because as I say, if I remove access to the setting file completely then it has no effect on the robot.

Thinking about it, I noticed that originally the robot user didn’t have permissions to edit the settings file (I have since granted access), I wonder what happens if the robot runs the first time without access to the settings file - could it make another copy somewhere else and look there instead…?

Note: The UiPath.settings is read when the UiRobotSvc is first started (if I remember right), so removing it won’t impact the robot after that service has been started. Also, if you look at the timestamp, the UiPath.settings file gets updated each time the UiRobotSvc is started. If the timestamp is not being updated, then that would be strange.

I hope you find your answer, because I am not sure from my end.

Hi @ClaytonM, do you mean the when the robot service runs? This is what i would expect (run robot.exe to initiate robot, it reads settings file, shows processes in system tray) but that’s not happening, i have turned the robot on and off many times and regardless of what is in the settings file it always points to three normal \Packages folder, and doesn’t leave a time stamp on the settings file…I’m baffled…

Yeah, let me clarify also.
Here is the service that controls the robot tray:
image

When that is “restarted” or “started” when you boot the machine up it updates the UiPath.settings. Like shown here:
image

If it is not updating the file with a new timestamp when you restart the UiPath Robot service, then something is wrong.

Regards.

Hi @ClaytonM, yes I have tried completely closing down the robot and the robot service in task manager too, and still no change. The settings file does NOT get timestamped when the robot service starts…

you might need direct support from UiPath. Here is the link to escalating a ticket: https://www.uipath.com/company/contact-us/contact-technical-support

Regards.

1 Like

@Djh

Did you solve this by chance? I am currently working on the same problem.

I haven’t I’m afraid, although I didn’t follow up with contacting tech support so thats still worth a try…