uiRobot gets uninstalled when I shut down my Laptop [Windows 10]

robot
robotservice
tray

#1

Why does UiRobot in the system tray get uninstalled everytime I shut down my Laptop?! It doesn’t make any sense! I have to re-install it everytime I turn the laptop on!
Does anyone know what the problem is??


#2

Hi @Duwa

It would be helpful if you can provide more details on the same, like Event Viewer logs and steps you performed to eradicate the same.

Meanwhile, please refer the below mentioned points which usually cause this issue:

There can be two situations:

  1. The system has application like DeepFreeze installed on your profile which reverts the system to the previous/defined state and hence it might revert it to that state and hence the new applications get uninstalled after every restart. Please confirm this issue occurs with UiPath only.

  2. The other scenario can be, your user profile is corrupted. You can confirm this by creating a new profile and installing the application in that or please restore your system to the previous stable state.

Regards

Rajat


#3

Hi @rajat.pandey

Sorry, I don’t know where to find the event viewer logs and regarding the two situations you said

  1. I am sure there is any such kind of DeepFreeze application installed in my laptop.The Issue only occurs with UipathRobot. I tried installing other applications and they were present after restarting windows.
  2. I created a new profile and installed Uipath studio and Robot. Same Issue has been encountered.

In my case, UIpath is installed under User’s AppData and I have to Manually install UiRobot from
“C:\Users\AppData\Local\UiPath\app-18.1.2\UiRobot.exe”. Only then I get the UiRobot in the System tray.

And also whenever I try to initiate a process/job from Orchestrator CE. I get an Error - “Cannot act as user ADMIN. Make sure UiRobot is running as a service!”

When I checked the “Services” window, I can’t find “Robot”, “UiRobot”, or anything resembling it in the services List. I went through the forum and tried a couple of suggestions posted by others but still no luck.

I completed Uipath Garduate exam and I stared the Orchestrator training but these installation Issues have blocked my progression. Can you please help me out with both these Issues - “UiRobot gets uninstalled when I shut down windows” and “Unable to find UiRobot service on Windows services List”.

Thanks,
Duwa


#4

Hi @Duwa

Regarding your first question. UiRobot doesn’t get uninstalled, it just closes because you turn off your laptop. And every time you turn it on you have to open UiRobot again. Studio also does that. It closes when you turn off your laptop and you open it again when you turn it on.

Now, “Unable to find UiRobot service on Windows services List” - this is not an issue, this is how it works because you have installed UiPathStudioSetup.exe. This is the Community Edition, which is free and has some limitations, one of them being that you have the Robot running in User-mode, not as a Windows service. I have explained all this in details here:

To solve your first request, you can add UiRobot.exe in the Windows - Start Up folder and it will open every time you turn on your laptop. You can find the steps here: https://support.microsoft.com/en-us/help/4026268/windows-change-startup-apps-in-windows-10


#5

Thanks a ton @ovi! :crazy_face:
I am finally able to deploy processes from Orchestrator, All your inputs were useful.:+1: