UiRobot does not exist in services

I am having an “error connecting to Robot service” in UiRobot.exe. I looked up the solution, and it says to restart it in services. When I go to services.msc UiRobot is missing. What should I do?

In your windows search bar, type “UIPath Robot” and see if you are getting the robot application. If yes, then click on that and it should appear in the right bottom tray.
This should automatically start robot service, if not go to task manager and restart service.

If you cannot wind UIPath Robot application from search bar, it means you don’t have it installed.
Try restarting the system and check again.
If you still can’t find then you have to re-install the robot using UIPath installer.

1 Like

I do have the UiRobot.exe file and I have tried to run it this way. When I start it, the UiPath logo in the tray is red and says “error connecting to Robot service”

Hey, That’s unfortunate.
Are you trying to connect your robot to orchestrator or just run the project from studio?

There is a reference post @ovi answered months ago. Check if this helps.

I’m suspecting the installation was not done properly.

Reinstalling worked, thanks so much!

1 Like