UiPathRobot.js - I have the localhost page running. But there is no reaction from page

I have been trying to get the embedded Robot sample app working, but I don’t seem to get any response from the page that is locally opened.

In other words, none of the Javascript is actually working.

cc: @evan.cohen

Has anyone tried this?

https://robotjs.uipath.com/samples

Thanks!

SOLVED!

The path to the script in the Boiler plate application is obsolete. This line in the index.html file must be replaced with the one pointing to download.uipath.com

<script src="https://uipathrobot.azureedge.net/Latest/UiPathRobot.js"></script> (Obsolete!)
	<script src="https://download.uipath.com/js/1.2.1/UiPathRobot.js"></script> (Valid)
2 Likes

I do see that this works as long as I deploy the process to a traditional classic folder. :slight_smile:

However, if I deploy the same process to the My personal workspace modern folder it does not work. :open_mouth:

I don’t get it, because the JS is able to get a list of processes and it can see the process name just fine.

If I click the Invoke button, I am able to trigger the process, but obviously that is not very useful because I need to pass parameters to it.

But if I fill in the form and click on the submit button, there is an error on Line #41 of the app.js script that indicates that the start method is inaccessible.

Line #41 is:

That is most likely because this line fails to initialize the object named BrowserEmbeddingSample as the script is initializing. The find functio is not able to return a valid process object with name that contains ‘BrowserEmbeddingSample’.

Is there a latest version of this script that works with Modern folders? :thinking:
Or, is the call to the results.find(…) just too early in the initialization process? :thinking:

Kind attention: @evan.cohen

SOLVED for Modern folder deployments. Although this solution defies logic, it works when the boilerplate process is deployed to a Modern and a classic folder on two completely separate tenants.

Fix to app.js - This line changes to:

Modern Folder Test:

Classic Folder Test:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.