UIPath to type into not working in the Windows Application?

I’m trying to use UIPath to automate which includes typing in a User Name and Password text field. The problem is UIPath doesn’t recognize that text field. Please find the attached screenshot. Please help me and support

let me know about application name.

Hi @Velan_Info5

Have you check the selector?
If possible can you share the XAML file?



If this a Java based application then try to install the Java Plugin and check

Else if this is developed in some old based programming then you can still check with the Image activities

Hope this may help you



Let’s first clarify that it’s not Java based application
And if it is then we have to install JAVA EXTENSION and only then we can interact with that application

For more details

And if it is not a Java application then we can try with other options apart from Click or type into activity

Use a SEND HOT KEY activity and use tab keys

Use n number of send hot key activity with tab key in it until we reach the field we need
It’s more like how we interact with application without mouse and only with keyboard

Even to the meter values
First save the value in a variable and pass that to SET TO CLIPBOARD activity
And when you want to paste that to the field use send hot key with key as ctrl+v
This will paste the value to that field

Hope this would help you resolve this

Cheers @Velan_Info5

Hi Palaniyappan,

Thank you so much for your quick response.

We have checked using SEND HOT KEY and SET to CLIPBOARD activity. Unfortunately UserName and Password text box not allowing Copy and Paste.

1 Like


May I know what kind of application it is ? I mean whether it is Java or .NET or any other ?

Hmm if it allows to paste manually then it should be possible with UiPath as well

But still let’s give a try with other options we still have

Did we try using COMPUTER VISION activities

Here you go on how to use it

Cheers @Velan_Info5

Hi Palaniyappan
We have tried the COMPUTER VISION Activates as mentioned below,

We have added the CV Screen Scope under CV Type Into and CV Click activities nothing help us.

We have used attached screen. Please help us how to proceed further.

1 Like

Hi Palaniyappan,

Any help on the above.

could you try send hotkey one by one?

No worries
Did we try with SENDHOT KEYS activity
It’s more like using only the keyboard without mouse to access elements on screen

Try using tab key in send hot key activity and use n number of such activities until you reach the field you want

To insert value use SET TO CLIPBOARD activity and pass the value you want as input to it

Then use a SEND HOT KEY activity with key as ctrl+v

It’s like pasting the value from clipboard

Hope this would help you resolve this

Cheers @Velan_Info5

Hi Palaniyappan

We have checked SEND HOT KEYS activities and its not working. Unfortunately UserName and Password text box not allowing Copy and Paste.

FYI this is very old application.

Please let me know how to proceed.

Did you try without any selector

Which means just use tab key and use n number of keys until you reach that field


Hi Palaniyappan,

Yes, We have tried as you said but nothing help me.

Please let me know is there any way to solve.

Hi Palaniyappan,

Any help on the above.