UiPath Terminal Cannot Access Field Meanwhile IBM PC/Mocha Emulator can


I have a following screen that has editable field (X column) in the right-most screen.
I want to type ‘X’ in the latest row, besides ‘+’ character.

When i do it manually using IBM Personal Communication, i can type X at the latest row, as you can see at following picture

But when i recording using UiPath Terminal, i cannot access that row.
I try send “Tab Keys” multiple times. When reach the fifth row and then i send the press key, it will go to the first row again.

I already tried many ways to type ‘X’, such as:

  1. Move cursor to the 6th row and send ‘X’ Keys. it not worked,it will type ‘X’ at the first row
  2. Invoke Down Arrow 6th times and send ‘X’ Keys. It also not worked, it will type ‘X’ at the first row
  3. Set ‘X’ value directly at coordinate 21,80 using Set Field at Position. But it throws an exception that field not found
  4. Set ‘X’ value after ‘+’ character using Set Field but it throws an exception that field not found.

I also confirmed that field can be filled with ‘X’ using Mocha Emulator.
It seems a bugs in UiPath terminal. Anyone can advise me how to solve this?



Finally i change the emulator from UiPath to IBM PC to solved this.
It’s not seamless modification because UiPath Terminal has different Key with IBM PC,
for e.g.:
F8 = Page down in UIpath Terminal
Page Down = Page down in IBM PC.

I also have to use get field based on coordinate in IBM PC.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.