uipath studio run error

error details:
Cannot create and populate list type System.Collections.Generic.IReadOnlyCollection`1[System.String]. Path ‘ReferencedAssemblies.$values’, line 1, position 379.

System.ServiceModel.FaultException1[System.ServiceModel.ExceptionDetail]: Cannot create and populate list type System.Collections.Generic.IReadOnlyCollection1[System.String]. Path ‘ReferencedAssemblies.$values’, line 1, position 379. (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
Newtonsoft.Json.JsonSerializationException: Cannot create and populate list type System.Collections.Generic.IReadOnlyCollection`1[System.String]. Path ‘ReferencedAssemblies.$values’, line 1, position 379.
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateNewList(JsonReader reader, JsonArrayContract contract, Boolean& createdFromNonDefaultCreator)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateList(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, Object existingValue, String id)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.ReadMetadataProperties(JsonReader reader, Type& objectType, JsonContract& contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue, Object& newValue, String& id)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObje…).

Can you explain the scenario?

ok,I setup uipath sudio on my local computer,bAfter the design, an error occurred.!
Attached is the screenshot,Thanks!
error|690x334

dear,

I successfully installed uipath studio,after design,Execution error.Please refer to the attachment for details.

Thanks!

(Attachment 2018-12-26_Studio.log is missing)

golden.niu@sscelite.com

Hi there, I encountered the same error message when I tried to run. Do you know how to solve this problem now and can you share it? Thank you so much.

can you share the workflow which gives you this error or are you getting this error for all workflows?

it is a very simple workflow as I have just started learning to use UiPath

I have the same problem, but it seems this issue is still open without potential solution. Anybody can help?

Thanks in advance.

Hi @Xin_Gao

I would suggest to reinstall the application from scratch and make sure no firewall or other protection software is interfering with the installation and the run of it.

To give more clues, you should check if all your packages are up to date and your Studio properly installed.

Hi there,

I have met the same issue twice whenever I upgraded UiPath Studio community Edition to newer version.

The major error is “Newtonsoft.Json.JsonSerializationException: Cannot create and populate list type”.

The root cause is “An incompatible version of Newtonsoft.Json has been loaded into the Global Assembly Cache (typically by another application)”.

The solution is replacing the .dll file in the GAC. Here is the steps:

  1. search “Newtonsoft.Json.dll” in your computer

  2. right click, open this file location (here is location in my computer for your reference: C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Newtonsoft.Json\v4.0_11.0.0.0__30ad4fe6b2a6aeed\Newtonsoft.Json.dll)

  3. go to this file’s parent folder (2 levels) “Newtonsoft.Json”, cut this folder, paste to other place for backup 3

  4. Lastly, reinstall the UiPath Studio, it works! :blush:

P.s. I wrote this solution in Chinese UiPath - issue - “Newtonsoft.Json.JsonSerializationException: Cannot create and populate list type System”

Hi all, though I didnt have the chance to try your suggestions, but still thank you for your ideas.

I solved the issue by reimage the windows 10.:slight_smile:

Hi there,

My corp’s security policy does not allow user to delete files under drive c.
The workaround does not work for me, any solution else ?
My version is 2020.4.3

Hi @chenyanfong

Please contact our technical support for direct assistance :slight_smile:
You can use this form: