UIPath Studio Is Not Responding - locks up on cut & paste

As an automated data quality engineer (DQE) and I need to read in a JSON file and extract each value for each item in the JSON file so that I can validate the values within the JSON by compare against expected results from my source system. In other words I need to extract all the values from the JSON so that I can validate the data.

Several months ago I created UIPath RPA to extract the data from my JSON and my RPA was working perfectly. Over the past couple days however UIPath has started freezing up for hours at a time over and over and so my RPA is essentially a “brick”. The action that is causing UIPath to freeze is copy & paste from text editor to UIPath. What I’m attempting to copy and paste is not a lot of data it’s just roughly 80 rows with 100 characters per row and I’m pasting into the “Code Editor VB.Net Code” that’s inside the “Invoke code VB.NET” UIPATH system activity.

I’m working with JSON in UIPATH and some of my schemas have 100+ elements so I need to construct an array programmatically so that I can be sufficiently efficient. Below I show one of my examples it’s a screen print and literally all I need to do is copy & paste an 80 row overlay/schema into the UIPath Code Editor and it freezes right here. Every time I try and copy & paste from my text editor to UIPath then UIPath freezes up with “no responding” and I have to force quite UIPath. This is very frustrating as I’m unable to do my job at the moment.

@PaulyE Try doing this, don’t copy directly from editor to UiPath

  • Try copying to Notepad or Notepad++ first then copy it to UiPath

Don’t copy/paste. Use activities like Get Text and Set Text.

Thanks for the suggestion. This is not when my RPA is running it’s when I’m developing my RPA. I have my JSON schema in Notepad++ and I need to copy & paste into a “Invoke Code” activity in UIPath.

Thanks for the suggestion. In my post when I said “copy & paste from text editor to UIPath” yes the text editor I’m using is specifically Notepad++.

@PaulyE Can you try with Notepad, First copy the data from editor to Notepad, then to UiPath

Thanks for the suggestion Ushu! I also tried copy & pasted from Notepad and I’m still getting the “(Not Responding)” error.

Is your project stored in a network folder? I’ve had issues like this when the network (VPN for me) is slow. It seems Studio is very disk-write intensive. Every little change you make it seems like it triggers disk writes as it validates what you changed. In some cases I’ve seen it take 10 seconds or more just to get rid of an error icon after I fix an expression.

Hi Paul! Thanks for your support. My project is stored locally on my C: drive which I sync with GitHub so no I don’t think that’s a network folder. I don’t really care how long it takes but I have let UIPath spin as not responding for over an hour before finally killing the session. Again, I’m attempting to copy & paste 80 lines of text (50-80 characters per line) so this is very small amount of data that I’m attempting to copy & paste that it can’t handle.

I’ve tried everything I can think of but UIPath just freezes up over-and-over. At this point my conclusion is that UIPath is not a good solution for data quality engineers (DQE) working with JSON data. I don’t claim to be a UIPath expert but I’ve had very inconsistent success using the tool to support my role as a data quality engineer. My object today is to extract raw data out of JSON and my conclusion is that UIPath is not a good solution for this type of task.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.