UIPath Studio freezes when I right click on project

When I try to right click on the project name, UIPath Studio freezes. I’m using Community version 21.4.3 now, but I’ve been noticing the error in previous versions.

1 Like

Hi @alvaro.j.nobre

Does a simple machine restart fixes the issue?

No, what seems to work is connecting the project to a git repository via PowerShell. When the project is connected I can right click the project name without any problem, however when I create a new project this is impossible.

This sounds super strange. Would you be able to:

  • record (or provide screenshots or a gif) the behavior?
  • generate a image report and send it to me via a private message @loginerror ?

We will further look into the issue.

1 Like

Thanks. We would still really appreciate the output from the image. It would help us reproduce the issue.

You can find it in your Start menu.

Hi @alvaro.j.nobre, thank you so much for your help. :slight_smile:

I’ve noticed from your video that when you create a new process, it seems to be under GIT source control already, but doesn’t load fully the status bar (lower right side of Studio) - this may be what is causing the freeze(it might actually be a very long loading time); a root folder from your project location C:\Users\alvaro.j.nobre\Documents\UiPath\ may be already under GIT - and when you right click the project name, it probably waits a long time to retrieve the GIT information for the number of commits, pushes and so on (I imagine your root folder contains multiple projects).
To confirm this, can you please:

  • enable hidden files and folders feature in Windows → View hidden files and folders in Windows 10.
  • go to your root project location (where you want to create the new projects) C:\Users\alvaro.j.nobre\Documents or C:\Users\alvaro.j.nobre\Documents\UiPath and check if a .git folder exists as a hidden folder
    If it exists, then it seems you somehow added it to GIT - and all subsequent processes created are automatically added under the root GIT folder.
    The solution for this would be to disconnect the root folder from GIT.

Please let us know what happens and thank you once again for your help :slight_smile:

2 Likes

That solved it. Thank you for your quick and effective response.

2 Likes

Really glad that worked! :slight_smile: Thank you as well!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.