UiPath Studio failed to detect the installed Edge Extension

The extension is installed and enabled on the browser.
I have tried to indicate element on the newest Edge browser but an error is shown. My studio is 2020.10.2 version with Enterprise License.
I tried to restart my laptop. Unintsalled the extension and reinstalled. The error is still shown as the pic.
Anyone has the same experience or any tips? :slight_smile:
Thank you for your attention.

1 Like


Welcome to uipath forum

Pls check this troubleshoot doc on edge extension and it’s common issues

Before you create your first automation projects for Edge, you must close the browser and terminate the corresponding process from Task Manager after you install the extension.

Cheers @IceCream

Try installing the extension using command line, tried in Edge chromium, it worked

  1. Change the directory to the UiPath installation folder (cd C:\Program Files (x86)\UiPath\Studio\UiPath).
  2. Use the SetupExtensions.exe /Edge command to install the extension locally, or the SetupExtensions.exe /EdgeGlobal to install the extension per system. A confirmation pop-up is displayed in the New Edge Browser (Chromium).
  3. Start (or restart) the browser, so the installation can complete. A new UiPath icon appears in the top right:

Were we able to indicate the elements now


@Palaniyappan Hi Thank you for your reply. I reinstalled the extension and tried with your suggestion. It is still the same issue. :thinking:

Did you try using command line too?

If so, then please make sure the Edge is installed in your system correctly. Check in the task manager if that shows Edge is running with elevated rights.

Command line and restart, this works always.

Thank you. How do you change the directory in CMD?Could you share screeshots? :thinking:

cd (change directory) is the command used to change the active directory in command prompt.

Got this screenshot that shows how it works for Chrome. Just refer this and perform the steps shared earlier for Edge extension


I don’t know what’s the issue?

actually you need to see where the UiPath is installed
usually it is in C drive hence in the standard documentation, it’s mention C drive.

i see in the screenshot there’s a S letter, seems your OS is installed in a drive which has letter S for reference

So just replace C in the start of the path with S

Alternatively, manually traverse to the path where UiPath is installed and then press and hold shift key, in the blank area and then right click and select open command prompt here, this eill eliminate the pain to change directory for you.

I know my UiPath is installed in C:/, I wasn’t able to switch S with C. So I tried the other option. There’s only open Powershell option… :thinking:

Open the command prompt

It’ll have S:/

Just type →

This should switch the drive then you can use the command sent earlier to do cd and then install the extension.


Are you behind any corporate policy?

Then it should allow by your administrator to allow this to group policy

Check below for your reference

Hope this may help you


Pls try reinstalling UiPath Studio and give a try

Once after reinstalling studio check whether edge extension is installed or not
If not then install and give a try on indicating the element

Please ensure the below conditions are met

  1. Studio v19.10.5 or v20.4
  2. UiAutomation v19.11.3 or v20.4.x
  3. Make sure that an official version of Edge Chromium is used (not Beta)

Check this thread as well
This has a different approach

Cheers @IceCream

I have downloaded also the chrome UiPath extension following my colleague’s advice and now everything works fine. :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.