UiPath Studio Enterprise Edition Not Recognizing Orchestrator As Enterprise Version

I have a locally unlicensed Studio Enterprise (version 19.10.4) which I am trying to acquire a license key from my trial Enterprise Orchestrator (version 21.1.27).

I have added my machine under the Machines tab of Orchestrator and under Orchestrator Settings of the UiPath Agent I entered my Machine Name, Orchestrator URL, and Machine Key. The Agent is showing a status of Connected, Unlicensed. Now when I go to select Acquire License Key in the UiPath Studio Let’s Activate window, I get an error on the bottom:

Orchestrator is connected, but the Robot is unlicensed.

And along the top of the window:

Locally unlicensed Studio Enterprise Edition cannot acquire a license from Orchestrator Community Edition. Please use Studio Community Edition.

I originally created my Orchestrator as Community and just today began the Enterprise trial. I’ve restarted my machine, logged in and out of Orchestrator multiple times, and created a new machine after the Enterprise Orchestrator trial had began and reran the Orchestrator Settings hook-up. I imagine the simplest fix would be to uninstall the local Studio files and download Studio from the Automation Cloud screen, as that worked well for my personal machine, but would like to avoid that hassle on this company machine if possible. I have gotten quite twisted around with all the different versions of Studio, Orchestrator and Agent/Assistant and would appreciate any help! Thank you!

Hello @djohnston!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi @djohnston,
I hope this video will help you:

Hello @Pablito, I appreciate your reply.

On my Users tab, clicking the plus sign does not give the Add Local User option. On the Automation Cloud Users and Groups screen there is no option to add another user, so I’m stuck on how to add a new user and therefore auto-provision a new robot.

Under Robots, I’m seeing the original autogenerated robot but it has a status of disconnected and no Machine listed. I’m unsure how to connect a machine or to get the robot to connect to Orchestrator outside of the UiPath Agent Orchestrator Settings connection I’ve tried.

I’m stuck on how to proceed.

Could you show how your Orchestrator settings in Assistant looks like?

I’m unsure if I have just been overlooking this in Orchestrator, but under the Default folder I have access to the Classic folder structure. From that Robots page, I was able to make a Standard Robot of type Attended and linked it to the machine I had previously provisioned. I reconnected to Orchestrator and the UiPath Agent is now saying Connected, Licensed. I can now start Studio, but because the robot is type Attended I can’t make any edits.

I need to be able to make edits, so I changed the type to RPA Developer Pro, reconnected the Orchestrator settings and was getting green connected, licensed. Now when I open Studio, it brings me to the Let’s Activate screen and when I click Acquire License Key Studio immediately crashes every time.

Hi @djohnston
It would be better if you can provide screenshots about the issue. Also, since you have the enterprise trial, you can reach out to UiPath Technical Support directly. If the issue persists that will speed up the resolution I guess.

Hello @JithinKP,

I was able to get in touch with UiPath Support and turns out the older version of Studio I was using does not support RPA Developer Pro robots. Once I changed the robot to RPA Developer everything was working correctly.

Thank you all for your responses!

1 Like