UiPath Stops on popup

I am currently working on an automation that mimics steps done by an individual within an application.

After the users enter the appropriate information a table with results is generated within the application. Now I need to Copy the results of the data into a data table or CVS or anything structured for that matter and then do some additional processing.

The problem is for me to be able to save that table that is generated, I need to click a button that brings up a popup that allows me to SaveAs to a particular location. The issue is that the minute the popup comes up the robot hangs, no error, no issues, just sits there and does nothing until I stop it. The curious thing is if I test the activity on its own it works, I can type into the popup, I can save it…etc

Things that I have tried:

  • Tried attaching the popup
  • Tried manipulating the TypeInto activity between Simulating Clicks or Sending Window Messages
  • Tried different WaitForRready Statuses
    -Tried activating the popup window

basically, the minute the popup windows comes up from this application, the robot just freezes and nothing else can be done. I am not sure if anyone has encountered this before but any help is appreciated.

Thank you,

@sasho1987
Have you tried to add one additional click activity on text box of saveas pop-up window before typeinto activity

I did - I tried adding a click activity before on separately and same issue, nothing happens after popup.

I even tried to “Click Before” property in the TypeInto activity as well.

Please uncheck simulate click or send window message property of click and type into activity if you didn’t

I tried various combinations and I have tried that as well.

So I finally figured it out. My TypeInto activity was not the issue, it was the previous two activities that generated the popup that was the issue.

There is a total of 3 activities, if the first 2 activities had simulate click checked off then the 3rd TypeInto activity would fail.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.