UIPath stopped reading pop up windows within excel after update to M365

Hello, I’m trying to essentially open up an excel file and click through the usual pop up windows I typically encounter(ie “This workbook contains links to external files…blab blah blah” and I want to click a button “update”) I also just upgraded to M365. Before I upgraded to M365, I was able to use the “Check App State” to see if there was that wording in a pop up window. However, after the upgrade to M365, using Check App State within the Use Excel File activity doesn’t appear to work anymore. Can someone explain to me how to read pop up windows within excel now? Note that I’ve seen similar questions to this but they’re all from several years ago and don’t seem to apply in my case. Thanks!


Have you just tried using GetText activity an Click?


Hi Kamik,

thank you for your suggestion. I just tried using that but I’m getting the same result. I think there’s something different about the pop up window, like UIPath doesn’t recognize the pop up window as being part of the “use excel” activity. I’ve included a screenshot of the pop up window in case that helps.

Have you tried spying it with different mode ? Win32, UIA or AA ?

Hi Kamil,

I’m still pretty new to UIPath so I’m not familiar with “spying”.

When I clicked on the pop up window, the properties screen said the "Window Selector(Application Instance) was:

…Is this the type of info you were looking for?

Thanks again for your help!