UiPath ServiceNow Integration - Insert ServiceNowRecord issue

Hi all,

I am currently setting up an API Integration between UIPath and Service Now. I am successfully able to retrieve Incidents using “Search ServiceNow Records”.

However, I am unable to use the activities “Insert ServiceNow Record” or “Update ServiceNow Record”. When I click “Configure”, I should be able to select the fields I wish to populate/update. Instead, there are no fields available (as per below):

In fact, when I click “Test”, I get an error:
“An Internal Error has occurred. It is recommended to restart UiPath Studio”

I have checked with my Service Now administrator who has confirmed that permissions are set up correctly on that side (Its also weird that I can retrieve Incidents ok).

Would anyone be able to assist with or provide some insight into this issue please?

Kindest Regards,
Billy.

Hello @Billy_Cussen!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Hi Billy - can you also please confirm the version of Studio you are using, and also the version of the activity pack? Thanks - Paul.

Hi @Billy_Cussen,

Refer below 2 videos for complete steps:


Regards,
Deepak

I am having the same error. UiPath.ServiceNow.Activities version 1.2.0, the latest version available; Studio version 2019.10.1. I am connected and can select an object in the Configure menu, but when I try to add a field nothing happens and if I try to test I get the same error @Billy_Cussen described.

@Billy_Cussen hey I had the same problem :frowning:

Hi Paul I got same problem, would it be possible fr you to provide us solution? Studio 2019.10 if I’m not wrong

A few things:

  1. The videos that deepak.rai6 cites are for a different activity pack and not for the one that is officially supported.
  2. If I understand correctly, you are putting an activity such as Get ServiceNow Record (see https://docs.uipath.com/activities/docs/servicenow-get-servicenow-record) in your scope and when you click on the drop down list of objects you are not seeing any choices. If so, have you validated that your account/role has the necessary permissions as described on this page?
    Troubleshooting Permissions Issues

Thanks,

Paul

Yes, I am able to access the same object correctly using any of the other activities - I can query it with Search, I can even update it with the Bulk Upsert activity which I am using as a workaround. This error only occurs when attempting to use the wizard as shown in the OP.

Your snow user is missing itil role :slight_smile: it took me a lot of time to get this

That does not seem accurate. Integration users should be given the most narrow set of permissions possible for security. ITIL is an extremely sweeping role with wide access; on top of that, adding an ITIL role would not solve problems for tables that ITIL does not have access to by default (such as CMDB or Test Management). Adding ITIL to robot users willy-nilly when they don’t need them seems like a minefield. Since the API bypasses all client-side validation, this could result in some gnarly issues if your business rules aren’t built to expect it.

It also doesn’t explain why my user is able to access the necessary tables using all the other integration activities without issue.

Test on the developer servicenow, check also uiteam pack for this im using this in work

These are really questions for your SNOW administrator to answer in how they are setting up permissions. The most common is that they create a role specifically for RPA developers to read from the two tables as documented and then put users in that role.

The robot doesn’t need these to run, in case that was not clear. These are strictly there for the designers.