UiPath Selector Issue

Good morning everyone,

I currently have a process where a portion of it works to click a drop down button and then the bot has to click an area from the dropdown called Review.

Now there could be multiple section in that drop down with multiple “Reviews” so the way I tried to solve for this is by using an Anchor base that finds the Title of the section using a Find Element and then it click on the “Review” area (using a click Image) after it finds the title. (Please note that normal click did not work in this instance and click image was the only thing that worked).

The problem is if there are a lot of sections, the “Review” that needs to be clicked could be not within the visible screen and potentially needs to be scrolled down to ( could be any number of scrolls).

is there a way using my Anchor activity, to find the title element of the section that contains the “Review” area and then scrolling to that section so my Click Image Activity would work.

Hello, @sasho1987
I got a little confused with your explanation, there are too many references to possible “Review” buttons, areas or sections, can you provide a printscreen of the dropdown and a short explanation of what you want to accomplish and the errors you are getting?

Happy Automation :robot:
Hugo Varela

Hi @hugo_varela , I can’t print screen due to the sensitive nature of the work so let me try and explain a little better with this screenshot. Imagine that you are on a site and you have to click a drop down. Once you click the dropdown, you will presented with a list of options that look similar to the screenshot. The drop down will be organized with a Title ( in this case the name of the person ) and under each title there are sub-categories ( review, Update, and Upload).

As the bot is processing a transaction, it will need to click the “review” that is associated with the name of the person that it is processing and not just any one of the reviews.

My initial strategy (which worked for most transactions) was to use an achor base where I first find the “name” using a “Find Element” activity , and then I use “Click Image” to click on “Review” (I used click image because the normal click activity with selectors did not work at all).

The problem is, there could be 1 or 100 names in that drop down and if the bot clicks the drop down and the name of the person that it is trying to process is way below on the list the “Click Image” activity won’t work.

image

Ok, thank you for the explanation, I understood everything very well now!
Well, I guess the image is not the best way to deal with the problem, is there a relation between “Review” and a specific person? What I mean is: is there any attribute that relates them?
First thing that comes to my mind is: first storing every ‘Review’ that you need and using a ‘For Each’ to iterate through all of them. If you use a dynamic selector, you won’t need to have the option visible. I suggest you try to use ‘UI Explorer’ to look for any pattern.

Hope this helps or gives you any other ideas. If there’s any limitation related to my suggestion, let me know. Good luck!

Happy Automation :robot:
Hugo Varela

1 Like

Hi @sasho1987

Try using Select Item activity along with dynamic selector. So even if your option is not visible the activity will be able to carry out the operation.

1 Like

Thank you @hugo_varela - unfortunately, I could not see any attributes in the “Review” selector that ties it back to the Customer Name which will then allow me to use a dynamic selector to click the correct “Review”.

I did find a work around solution. I kept the “click image” activity to click the “Review” section, but I inserted a “Hover” (hover over customer name since I have that data from the transaction item) activity before the “Click Image” activity, so the bot will scroll down to the appropriate customer name , hover over it and now the click image works since it is visible on the screen.

I am not sure if this is a best practice method but it is working so far.

Interesting. I never thought of using “Select Item” activity, I will definitely give it a try :slight_smile:

1 Like

@juveria.siddiqui - I tried using “Select Item” and it unfortunately did not work. I posted a work around solution that I ran across while replying to Hugo’s comment.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.