UiPath selecting entire window instead of selecting a particular element in App


my workflow ran without glitches yesterday but I’m not sure as to what went wrong today all of a sudden (I didn’t change anything). I ran it again this morning as I was preparing for a live demo for my manager and noticed that UiPath stops when it gets to ‘Attach window activity’.

It was when I tried to re-indicate my elements on screen that I noticed that UiPath was selecting the entire window instead of the elements. Has anyone experienced this before? How did you go about solving it?

Hello @ceceliaa34,

Did you verified if the UiPath web extension is enabled on your Browser?

The behavior from above, usually is related to that specific extension when is not installed/enabled.

I hope it helps.


Make sure you do not have multiple windows open to the same site. Also, the link may have worked the first time do to the link during that process. You can always try repair link to see if perhaps the selector needs a wild card for dynamic portions of the selector.

the app in question is not a web one. It’s a java application on my machine. Was working fine throughout last week. wonder what changed yesterday :frowning:

Hi, thanks for your feedback.

It’s an app on my machine. Was working fine last week until yesterday :frowning:


If you use the community version, it might been updated to the latest version, the one that appear 2-3 days ago.

If that’s the reason, you should try to install/update the Java extension from the Studio.