UiPath Screen OCR: Now in Public Preview!

Yes in the future an API key will be needed (@jayson.actimai)

Yes it is

It seems not to work with elements from our ERP. It returns “¿e”. While Tesseract works perfectly. see screenshots:

UiPath Screen OCR

Tesseract

For the people that get null output. Seems like you found a bug (thx!) and the OCR activity itself doesn’t output a value. That’s because it’s not the intended way of using it (it will be fixed nonetheless).
Here are 2 ways how it’s supposed to be used:

Usage in Get OCR Text

The output variable should be on Get Ocr Text, not the OCR itself, you may change that at any time.

.
.

Usage in ComputerVision (Cv Scope)

The output variable should be on CV GetText, not the OCR itself

1 Like

Could you pls add/send a screenshot of the app?

1 Like

A clarification for everybody

As it says in the original post, this OCR is intended for application screens and digital text. So it won’t work great (or at all) on scanned documents, handwriting, etc. We’re working on that as well, but we’re not there yet.

4 Likes

Yes, this activity uses an online OCR server. On closed intranets it won’t work.

The activity is currently in Preview, so use in production at your own risk, we don’t recommend it. But we’ll release it to General Availability soon and you’ll be able to use it safely in production.

3 Likes

:+1:

1 Like

Hi @Cosin,

I have used UiPath Screen OCR preview in my Enterprise edition of UiPath Studio with
computer vision 2.0.0.

Used this to scrap data from few online receipts.

The OCR is capable of identifying almost all the elements in the receipt. Is there an option to change the anchor element ? The AI is super fast :smiley: (CV Get Text activity) and goes back to UiPath Studio as soon as it finds the near by element. (e.g. I would want to change the anchor to be set to either Total / Sub Total in the receipt)

The OCR interprets Pound symbol £ (e.g. Total £10.00) into incorrect unicode character…

I will try few more and PDFs and see how it goes…

Thank you
VJ

Here you go. It is PeopleSoft HCM

I’ve been trying it for a couple of hours - It works great, it’s significantly more reliable than Tesseract esp. with some texts (55/56, punctuation marks)

The only thing it’s missing is the “Allowed/Restricted Characters” option from Tesseract.

1 Like

Hi Cosin,

In the first usage with Get OCR Text ‘client’ and UiPath Screen OCR. It is working for me when I get the output from UiPath Screen OCR activity…

Though, I understand it is explained above the other way around, what is the purpose of the Text property in OCR under Output category ?

Thanks
VJ

UiPath Screen OCR takes image as an input. Image can be a poster,Scanned invoice or pdf to jpeg and the results/output were far better than teserract and microsoft OCR. Tried combination of 16 posters,invoices and PDFs and writing this review.

Good job team UiPath

2 Likes

This is pretty awesome! I haven’t found any real issues. Mainly using it to read pdfs

2 Likes

Can i use this for Digitize document (Intelligent OCR activities ) ? If that is possible i used getting error

I’ve tried to use the UiPath Screen OCR to look at an image to see if it can get better results than the Microsoft OCR engine.

What I’m doing is putting an image into an image file using the Load Image activity. I then pass that image file into the OCR engine and have a String variable in the Text location of the activity.

My results for the Microsoft OCR Engine is some of the text from the image (sometimes correct, sometime incorrect).
My results for the UiPath Screen OCR Engine is the error “Error performing OCR: An error occurred while sending the request. ScreenOCRErrorRunningEngine”

I’m unsure if there is an error in how I set this up or not. I’ve tried it in the Computer Vision screen recording and was able to get some results, but not many.

Any help would be appreciated…

i am facing problem in the last days with this
ScreenOCRErrorRunningEngine

Perfect. It doesnt work

Hi

I’ve been using the UiPath Screen OCR since the day it was released for public preview and I must say that it is the best OCR I’ve ever used. UiPath OCR solved
a problem which I was having for almost over 2 years. However, since last 3~4 days it has stopped functioning with the below error message. Can someone please have a look and provide a resolution, would I be able to use it again, it was working brilliantly?

Regards

Vikas Kaushik

Hi @Jom4ick @luchovelez @VikasSteria

We updated the first post. Please check it out:

To get it to work, you now have to provide the CV API key which you can get from your Cloud Platform licensing tab.

4 Likes

Hi, just wanted to find out if anyone has this error, or how do i fix it…when I’m setting the cv screen scope…and am selecting the region, i always get a response “Response from server is not valid”…Getting the same error with all engines…Am i doing something incorrect…I’ve tried different engines as well

Thanks!!