Uipath Robot Tray Error - Logon failure

robot
tray

#1

Hi all,

When I try to launch a robot from the UiPath Robot system tray, I keep getting an Error:

  • “Logon failure: unknown user name or bad password”
  • “An error appeared while executing TestRobot. Error message: Logon failure: unknown user name or bad password”

However, when I run it from the UiPath Studio pressing the Play button, the process runs perfectly with no issues.

Someone knows why I cannot execute it from the UiPath Robot System tray and has a solution?

Thanks in advance!


#2

I faced a similar issue when trying to launch a job from Orchestrator.

The issue was with the username. Please retrieve the username using “whoami” command and use it for login.
In my case, I used the display name of my user account which was incorrect. For example, if the display name was “My User” and the actual username was just “User”, using the display name would cause the login to fail.

There are many steps like this in Orchestrator setup that require deeper investigation to fix.


UiPath Orchestrator - Job Faulted
#3

@marina,
Did the above reply provide any hint towards the problem?


#4

I tried with such command and introducing the correct User and Password but now pops up a different Robot Tray Error. Here I attach a screenshot of it:

s

Thanks for your help!


#5

Looks like a permission issue when trying to access files or folders.
Are you running UiPath Robot as an Administrator?.
I do so and I don’t see such permission issues.


#6

I have a similar problem. I can execute a job “Job A” successfully on my PC from Orchestrator or launch it from Studio, but when I try to run the same job from my system tray I get the Login Failure.

This is puzzling, because if I’m able to invoke it from Orchestrator, my credentials should be correct right?


#7

Yes it is tricky!

But at the end I managed to solve the problem:

I was logged at several users and looks like Windows was messing around with those multiple opened sessions.

Check in how many users are you logged in navigating to:
Control Panel > All Control Panel Ítems > Credential Manager > Windows Credentials

Hope this helps!


#8

Thanks @marinabir94. My solution also was in the Credential Manager but slightly different. My password had to be changed per company policy. I had to update credential manager with the new password.

Previously, you could do this right through the local bot. I’m not sure why the feature changed. It was a very good feature.