UiPath Robot上にpublishしたファイルが表示されない

UiPath Robotにおける質問になります。

UiPath.SettingsのNuGetServerUrlを変更し、
別のフォルダに.nupkgファイルが出力されるように変更を行いました。

Studioでのpublishは上手くいき、想定通りのフォルダにファイルが作成されたのですが、
UiPath Robot上に表示がされない状態となっています。

UiPath Robot上に表示させるにはどのようにすればよろしいでしょうか?

こんにちは!

Studioでpublishあと
UiPath Robotをリスタートしてください。

rajeev85さん

ご回答ありがとうございます。

ただ、以下の内容は試しており、それでも表示がされません。
・サービスの再起動。
・PCの再起動。
・robotの再実行

UiPath RobotをOrchestrator に接続されていまか? ほかのフアイルが表示されるか?

rajeev85さん

すみません。記載が漏れていました。

オーケストレーターには接続していません。
また、一切何も表示されていません。

NJNさん、

ご返事 ありがとうございます。

以下の内容教えてください

・UiPath Studio version
・UiPath.Settingsの位置

rajeev85さん

・UiPath Studio version

2018.2.3
・UiPath.Settingsの位置
ProgramData\UiPath

になります。

NJNさん

UiRobot.exeの位置も ProgramData\UiPathの中ですか?

@NJN さん、こんにちは
下記を参考にローカルドライブでもURL表記にしたらうまくいきました。

Orchestrator に接続している場合、どう対応すればいいのでしょうか。
Orchestrator とdisconnectすれば、見えるようになりますが。

こんにちは。
この件はURL表記にして解決したとの事ですが、こちらではNuGetServerUrlをURLで
記載しても、Publishは期待通りのフォルダに生成され、UiRobotの画面には表示されない
事象が発生しています。
Orchestratorは利用していません。
何か他に気を付けるべきことがあるのでしょうか。

@yuko5334 さん、こんにちは

Publishは期待通りのフォルダに生成され、

UiPath.Settingsファイルは、StudioのPublish先には作用しません。Publish時にCustom URLが指定できますので、そこで目的のフォルダを指定してください。

ありがとうございます。しかし、Uipath.SettingsのNuGetServerUrlを変更することによって、
Publish先は確かに変更されました。記述はURL形式にしています。(Ex. file:///o://aaa//bbb…)
同じ設定を利用してUiRobotも参照しにいく認識ですが、表示されません。
接続先は、ローカルドライブではなく共有サーバです。このあたりに注意点があるのではと
考えています。

私も同じ状況です。
Uipath.settingsのNugetServerUrlを、URL形式で記述してUipathRobotを
立ち上げ直してみても認識しません。
何を記述しても「C:\ProgramData\Uipath\Packages」以下のnupkgしか
認識されませんでした。
逆に一行まるまる削除しても、上記フォルダ内にnupkgがあればRobotで認識します。
settingsファイル削除しても、nupkgさえ上記フォルダに入っていれば正常に
パブリッシュされ、実行もできました。

環境は、CommunityEditionです。
パブリッシュ参照フォルダは、LAN上の共有フォルダ及びCドライブ内どちらとも
試しましたが変化ありませんでした。
他にもUipath.settingsが存在してそちらを参照しているのではないかと
思われるくらい設定が全く反映されません。

情報お持ちの方いらっしゃいましたら、ご教示よろしくお願い申し上げます。
社内でライブラリやプロジェクトを共有、一元管理するのが目的で共有フォルダへ
保存したいのです。

便乗する形で恐縮ではございますが同じ状況と思いますのでこちらに記入させて
いただきました。
よろしくお願い申し上げます。

こんにちは

2019.7のCommunity EditionならUiPath.settingsの場所は
C:\Users[ユーザー名]\AppData\Local\UiPath
にあります。

変更の反映には
UiPath.Service.User.Host.exe
の再起動が必要です。
(わからなければOSの再起動でもOKです。)

1 Like

@Yoichi
ご回答ありがとうございました。
解決いたしました。
再起動に関しては、UipathRobotのプロセスのみ殺していたので大変参考になりました。

私が躓いていた内容は、以下の通りです。

  • パブリッシュ先のパスに、日本語のフォルダが存在しているとUipathRobot側で認識されなかった(全て英語名のフォルダにすることで回避)

    c:¥太郎¥Uipath ⇒ C:¥tarou¥Uipath

  • パブリッシュ先のパス記入書式が誤っていた。(URL書式で記載)

    c:¥hogehoge ⇒ file:¥¥¥hogehoge

  • パブリッシュ先のパス記入書式が誤っていた。(ディレクトリ区切り文字を¥⇒/に置換)

    c:¥hogehoge ⇒ file:///hogehoge

  • 「Uipath.settings」変更を反映させる際に「Uipath.Agent.exe」しか終了させていなかった

    タスクマネージャー詳細タブにて、
    Uipath.Agent.exe
    Uipath.Service.UserHost.exe
    の二つをタスクを終了

以上4点を実施することで、任意のパブリッシュ先をUipathRobotに認識させられるようになりました。
ご教示ありがとうございました。

1 Like

こんにちは

おそらく文字コードの問題と思われます。UTF-8で書き込めば日本語も通ると思います。

@Yoichi様
こんにちは。

メモ帳で編集しており、ANSI形式での保存となっておりました。
ありがとうございます。