UIPath Robot log level setting doesn't work

robot
logs

#1

Scenario:

It upload all level of logs to orchestrator. Even if I set the log level to warning, the trace and info level still been uploaded. I have never change any setting for the Orchestrator, so this issue come with default.

Steps to reproduce:

Current Behavior:

Expected Behavior: should only upload the log whose are higher level than setting.

Studio/Robot/Orchestrator Version:Version 2016.2.6274

Last stable behavior:
Last stable version:
OS Version:Windows 7
Others if Relevant: (workflow, logs, .net version, service pack, etc):
image



#2

Hi @tomy

Does this happen when running from Studio directly, starting from Orchestrator, or both?


#3

This happen when running from Studio directly, I haven’t try it on Orchestrator yet.


#4

For me it works as you said if running from Studio, but from Orchestrator it respects the settings and only sends what it should.
Still a bug IMHO.
@qateam


#5

Studio logs everything. The settings that you refer is for robot (with Orchestrator).

image


#6

But it also sends everything to the Orchestrator.
In certain situations it would be preferable if you could log information locally without sending it to log storage - f.e. if I’m debugging something related to customer data I want the logs, but I don’t want to store it in Orchestrator (as f.e. it’s agreed that no personal information can leave customer network). In those situations you either need to disconnect (which is not always feasible as you lose assets access) or use message boxes (which are a pain).
Being able to set what level is sent to Orchestrator (or even disable logging to it for debugging purposes) would ease that pain.


#7

Agree. When we develop something locally with queue, we have to connect to orchestrator. but if it logs all the information when we do debugging and developing, those are logs we don’t need to be put on Orchestrator…

Regards.
Tomy


#8

to be clear here, please confirm:
studio/robot version is: ?
orchestrator version is: ?


#9

At this moment is by design.

As a workaround you should disconnect from Orchestrator when you develop workflows.


#10

It’s really pain getting all log data to orchestrator during development/troubleshooting. It is nice if we have one more item in options menu under execute tab as enable/disable log in orchestrator. So this sticks to studio like the one in UiRobot.


#11

Thanks. I’m looking forwards to the new feature come out.


#12

Not necessarily by design, I think this was not considered up until today and there are reasons to back this behavior up. I would mark it as a potential improvement. I like the idea of switching off logging to Orchestrator during development to only log locally. If you have a better idea on how this should behave please let us know.


#13

Hi,

It is possible to configuration set a minimum log level which would be accepted by the Orchestrator
inside web.config you can add the minlevel attribute for Robot.*

It is specially useful to avoid filling up the Database with useless trace logs but also for readability.

With more advanced configuration, it is also possible to make only those traces logs to be stored on a text file or to elastic search only.

Trace log would still be stored by the robot locally and would be displayed in studio.

Cheers