UiPath Robot has stopped working

Dear all,

we are currently in development phase of 4 processes together with 3 other guys.

We work on the same server, but only me encouters this problem which you can see on this pictureerror

I encouter this only sometimes, sometimes the robot finishes with no problems. However, colleagues had never experienced this.

Do you have any idea what could be the reason? I actually develop the robot in state machines, but they dont. Can this be the reason? DOes it need more capacity from CPU?


This might be the problem based on UiPath Robot services

Ashwin S


and what should be the problem in services? It is just started or not. How should this be adjusted?

Hi @mario,

Ctrl+R-> “Services.msc”
Find out UiRobot service & start it

Refer below if it’s not working. @richarddenton



This cannot be the cause…robot is running and suddenly this pops up and it stopped.
Services does not work like that…it cannot turn the robot off during run…

I have the same error and I tried the instruction above but unfortunately the error is still showing after a few second after playing the workflow.

Any other options to solve this?

I also still nneed the solution

I keep getting this error intermittently as well

Any updates on this issue?
I’m using Studio Community and the robot crashes from time to time.
My process uses a CSV file as input data and for each line it goes to Google Adwords and clicks some OCR text (or clicks relatively to OCR text) for at least 5 times per CSV row (sometimes more). It doesn’t matter the CSV size - it crashes with 4 lines and also crashes with 90 lines, …, and sometimes it doesn’t crashes at all.

From what I managed to observe, the crash always happens when the robot must click relatively to a OCR text.
The activity I use for clicking is Recording → Citrix → Text → Mouse → Click … Because the elements in the page are in an iFrame, the robot doesn’t figure out the target so I must use OCR.

I’m running the robot on 64 bit Windows Home, i7 - 2.7 GHz, 8 GB RAM.



Hi @crimaru,

Thanks for the detailed explanation of your wf. Now we need few more things for my colleagues to properly investigate this crash.

1)Run DiagTool:

  • Open the UiPath Robot installation folder: %localappdata%\UiPath\app-18.1.3
  • Open a Powershell or CommandPrompt window
  • .\UiPath.DiagTool.exe -f ocr_relative_click_crash_report.zip

Then you can find the report file on your desktop.

2)Collect some low level traces and share the .etl file:

  1. enable low level tracing:
  • UiPath.settings file - LowLevelTracing parameter set it to true
  • or from command line UiRobot.exe --enableLowLevel
  1. use UiExplorer to select something in the app
  2. disable tracing:
  • LowLevelTracing parameter set it to false
  • or from command line UiRobot.exe --disableLowLevel

Please share these files here or PM me and we’ll make this work somehow.



I’m getting the same error, except I have no clue what causes it. The robot is running unattended every night, and every now and again I wake up to see the UiPath Robot has stopped working popup. The robot logs give me no indication of where the robot crashed. If the popup is not handled by a human (by clicking “Close program”), it prevents the robot from running future unattended processes, which in essence means that the robot becomes useless.

About the robot:
The robot is working within several web-pages in Chrome, gets data from an API, reads data from Outlook, creates and saves 50-250 mail drafts, creates several csv-reports, and sends out one mail per night.

I am running UiPath Studio Pro, version 2016.2.6274.

How do I find the reason for the crash, and how do I prevent the popup from blocking future process runs? @ovi, any input?

1 Like

I was getting this error on the second iteration of a for each row activity that was executing a query on an access DB. The first row of query list would work but the second would throw this error. Swapping the order of the queries didn’t change the result, the second iteration would always cause the “UiPath Robot has stopped working” message to appear. This started occurring on multiple automations I’ve created that worked previously and I’d made no edits to them. I was able to remedy my issue by wrapping my execute query activity in the “Start Transaction” activity.

1 Like

Hi all,

Has there any solution to this problem being addressed as of yet? I’m getting this also in multiple automations.

Curious thing, I have 3 bots running the same automation and it’s only failing in 2.



1 Like
  1. What robot/studio version are you using? Are those HD robots?
  2. Did something change on the environment when this error started to appear? Like windows update, package update etc?
  3. Are doing any heavy Log message or Write line activities in the workflow? There are some out of memmory issues that look like that.
  4. Have you tried runing from studio or robot tray to see if this happens?

Hello TDagsvik

we are facing the same issue, We are running 10 unattended robots which scrape data from different websites and update the details in DB. Today all 8 robots crashed and all these were stuck and not available to process remaining requests. We have 2 workflow files one Main workflow and others are child workflows, When we make the child workflow isolated (in Invoke workflow activity) the error is passed to the Main workflow and the crash pop up never appears. This works fine on my local machine, but not on the servers. We still see the crash pop up appear and until a human goes and clicks OK the robot is stuck.

Does anyone know why the pop up appears even though the child workflow is running in isolated?

Have you logged a ticket on our suport platform?

… now that you mention it, I think in my case was a windows update pending. After updating it never happened again… My process runs one day every month so I’ll keep an eye on this scenario with the windows update situation.


No I have not raised any ticket. Could you please let me know where should I be raising a ticket?

This is for licensed users only, if you did not purchased one, we can help you only on the forum.

I see. Thank you! Our Orchestrator is licensed but we don’t have any license number. where do we find the license number?