UiPath Robot Error - Communication Error with Robot Service!

Hi,

When our robot executes, it can not get any data from Orchestrator. For example, when the robot tries to read the asset value with the get asset activity, or when I try to run the version of the project that does not exist in the robot’s local (while downloading the new version via orchestrator), it gets this error. You can see this error in the screenshot number 1 below . More detailed information about the error is available in the event viewer the ( screenshot number 2) .

Robot services are running( screenshot number 3 ). I restarted a few times but it didn’t work.

Both studio and robot are licensed on orchestrator. When I open UiPath Studio in the development environment, there is no problem. Although activities such as “Get Asset”, “Get Transaction” that pull data through the orchestrator work successfully in the development environment, the same activities do not work in the robot environment. When I start the Uipath Studio program in the robot environment, there is an error that appears in the screenshot number 4 below.

I also reinstalled Studio & Robot but no chance. Same error still here :worried:

I look forward to your help and suggestions.

[SCREENSHOT NUMBER 1]

[SCREENSHOT NUMBER 2]

[SCREENSHOT NUMBER 3]
Screenshot3

[SCREENSHOT NUMBER 4]

Hi @erkanceylan,
Any chance that a firewall or proxy is blocking your connection? Is this a fresh Studio installation? Any recent update?

This machine is VDI server. And we use this machine as development environment as well. There are 2 different user, user1 for robot and user2 for UiPath Studio. When i connect with user2(for development purpose) this error not occurred. Robot was working properly until last week. Beacuse of this i dont think there is blocking proxy or firewall rule.

I don’t know what you mean by fresh installation. But we uninstalled all the UiPath programs from robot machine and installed again.

Our robot version is 2020.10.2 and orchestrator version is 2020.10.1

All seems to be fine. Initially I was thinking that it might be issue related to the difference between Studio and Robot version. As I understand you are on the Enterprise plan. If yes then I think you should definitely contact with our Technical Support.

Yes, I have contacted with technical support. Tomorrow we are going to try to troubleshoot together. I will consider your idea. Version difference might been caused this error.

1 Like

Unfortunately, we could not solve the error with uipath technical support. It was a very strange error. IdentityService was saying that the robot’s client secret is invalid (although it is the correct value). We uninstalled the Orchestrator with UiPathPlatformInstaller.exe and reinstalled it and our problem was resolved. I think it’s a strange bug that the product team should investigate.

Thank you for sharing this. Have you informed our Technical Support about fact that the reinstallation helped? I’m asking because if they don’t know you could share me the support ticket number so I could let them know.

Yes, we have informed them. They helped during the reinstallation.

We decided to reinstall because of production was suspended for a long time.

Thank you for information. If they were by it then for sure it will be investigated internally :slight_smile:

1 Like

I had the same issue. In my case, I solved it recreating the bot and machine once again.

2 Likes