Uipath.Python.Host32 has stopped working

I have used Python scope and within which Load Script, Invoke method and Get Object activities are used to run a python code.
Still i am getting the error of Host 32 not working.

Hi @Athulya_S_Chandran ,

Downgrading the activity pack and re-installing the latest activity pack from Package Manager. Then restart the machine and can solved the issue



Welcome back to UiPath forum

re-check your environment, as I believe the correct Anaconda installation or Python interpreter is NOT being referenced. which causes this issue. Also at the moment, no support is available for Python 3.7 + so you need to ensure that you are using supported python variant.

Cheers @Athulya_S_Chandran

Thank you for all the replies.

The reason for this error was that multiple version of python was present in my system.(3.10 and 3.6.8). While the bot is running the script its getting triggered in an another version which is not supported by the script. Hence the resolution was that i have marked the default version of python as 3.6.8 for the system by changing the values in Environment variables and then tried tried.

After changing these values, i got the same error because pdf miner package was not supported so i have installed the same into 3.6.8 version and tried executing the script which ended up successfully.

Tried this but was not helpful.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.