UiPath.PDF.Activities Issues - Studio 2022.10.1

Greetings all,

I am using UiPath Studio Community, and after upgrading to the latest version, I am unable to add UiPath.PDF.Activities.

It is giving me the following errors:

NU1103: Unable to find a stable package UiPath.DocumentUnderstanding.Digitizer with version (>= 2.5.2)
  - Found 13 version(s) in https://pkgs.dev.azure.com/uipath/Public.Feeds/_packaging/UiPath-Official/nuget/v3/index.json [ Nearest version: 2.6.0-alpha.3042859 ]
  - Found 13 version(s) in Official [ Nearest version: 2.6.0-alpha.3042859 ]
  - Found 1 version(s) in C:\Users\sc795p\AppData\Local\Programs\UiPath\Studio\Packages [ Nearest version: 2.3.1-preview ]
  - Found 1 version(s) in Local [ Nearest version: 2.3.1-preview ]
  - Found 0 version(s) in https://api.nuget.org/v3/index.json
  - Found 0 version(s) in nuget.org
  - Found 0 version(s) in https://gallery.uipath.com/api/v2
  - Found 0 version(s) in Connect


Cannot load assembly: C:\Users\sc795p\.nuget\packages\uipath.pdf.activities\3.10.1\lib/net6.0-windows7.0/UiPath.PDF.dll : System.IO.FileNotFoundException: Could not load file or assembly 'UiPath.DocumentUnderstanding.Digitizer, Version=, Culture=neutral, PublicKeyToken=null'. The system cannot find the file specified.
File name: 'UiPath.DocumentUnderstanding.Digitizer, Version=, Culture=neutral, PublicKeyToken=null'
   at System.Reflection.RuntimeAssembly.GetExportedTypes()
   at UiPath.Studio.Plugin.Workflow.Services.AssemblyContainerBase.AddAssemblyInternal(Assembly assembly, String path)
   at UiPath.Studio.Plugin.Workflow.Services.AssemblyContainerBase.<>c__DisplayClass15_0.<ProcessAssemblies>b__0(Tuple`2 range)

It looks like it is the DocumentUnderstanding Digitizer it is having issues downloading/updating.

Any help is greatly appreciated.

Thank you kindly.

Hi @Sc100
Restart your Machine Ones then Select all source from Manage Packages and Try to repair packages.

Loveleet Saini

I have restarted. Still getting the same error.

How do you “select all” source from manage packages and then repair? I cannot figure it out from the “manage packages” screen.

Thank you

In Manage Packages, Go to setting, Check all the Package source.

Then try repairing dependecy

I’m getting same error with UiPath.PDF.Activities
After upgrading to 2022.10.1 and update from legacy to windows, my project has an issue in the read text from PDF activity. I did update the dependencies to UiPath.PDF.Activities = 3.6.0 and then to v3.10.1 but it didn´t work.

I did that “Restart your Machine Ones then Select all source from Manage Packages and Try to repair packages.” , but the issues keep going.

Please help !!!

Hi @Sc100,

Add the following to your Package Sources:
https://packages.uipath.com/activities/api/v3/index.json or https://www.myget.org/F/workflow/

Hope this helps!

Kind regards,

Robert, you saved the day! Thank you! It works!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.