UiPath.PDF.Activites version removes all PDF activities from studio

Scenario: Updated UiPath.PDF.Activities package to the latest stable release which is This required a restart of Studio. Upon restart, all PDF activities are no longer found anywhere in the activities pane.

Studio/Robot/Orchestrator Version: 2018.1.2

able behavior:Last stable version:
OS Version: Windows 7

We are working with a project that involves reading hundreds of thousands of PDFs for text extraction. Since this newest update will break workflows using previous versions due to the new engine, we would like to use the newest activity so we won’t have to re-configure at some point in the future

Hi @Dave,

Had a similar situation and switched back to the previous version:1.2.6863.34697 and the activities were available again.

I wonder if the new PDF version is compatible only with UiPath 2018.4 or above; more like a backward compatibility issue

I’m looking forward to hear from others to see if my assumption is right.



It’s very possible. Reverting to works fine for me. It seems like a massive oversight by UiPath to not even mention this in the release notes. It shouldnt even be available to those with incompatible versions if that’s the case

Hi @Dave

You are right that new versions of Studio and of activity packages should not break the old workflows.

Could you post you errors here? Does the activity package fail to install?

It’s a shot in the dark, but it might be that some dependencies were not pushed correctly to the Stable channel together with the main package. In this case, adding this beta feed might help here:

It’s a wild guess though, and normally such thing doesn’t happen often. Worth giving it a try though.

@loginerror I have attached pictures of a sample XAML with a read pdf activity. It is working as expected with pdf activity pack Once upgrading to the activites disappear within studio and an error is shown that states "Could not find type ‘ReadPDFText’ in namespace ‘http://schemas.uipath.com/workflow/activities’. Row 57, Column 6

Please upgrade your Studio version to 18.4.x and let us know if it fixes your issue

1 Like

hey just update the tool it should be working for you as i was using the same activity its providing the same result no issue till now

I am unable to upgrade in my environment. Is this a known issue for versions below 18.4?

Hi @Dave,

Yes, the new activities use a newer .NET Framework (that Studio uses since 18.3.*) so they are not compatible anymore with older version of Studio.

We will update the package description to make the compatibility known.

1 Like

Hi, i am having the same issue. However, i am using the latest version 19.5.0.

Hi @sangasangasanga

Could you post a screenshot or some error logs? Does the error happen after you’ve created a new project and tried to install the latest PDF package?
Have you checked all solutions suggested above?

After the uipath auto updated, I ran a previous script i did some months back. That’s when the error came. Atfirst the PDF reader in the new package was reading alot. Then the PDF package was missing and I add it to the beta activity feed. Then I am currently using a version lower.