UiPath Orchestrator APIs not working since Cloud Platform Release


i have tried with admin, tried in both fields and i can’g get past this error

1 Like

waiting for your reply… what it still does not work for many of us?? thread has full detail about issue…

1 Like

Don’t know what to tell you mate. Wait for an official reply.

2 Likes

Me also having same issues with API

1 Like

does anyone also have a problem with resetting password? am not getting the email to reset so i can get my password for the API body!

1 Like

Checkout my colleague’s @tarekmadkour post

3 Likes

Kamal - Please check the thread @andraciorici just referenced above.
Basic auth is only enabled for accounts that were migrated from the community orchestrator and for the username that already existed on the community orchestrator.
It will not work with any new accounts or tenants created. It will also not work for new users added to the accounts.
For new accounts / users, we will have a new method for API authentication that we will be publishing within a week.

Is the account you’re trying with a new account or a migrated account? If it is a migrated account, are you using the exact same username and password that you used before migration (e.g. last week)?

5 Likes

Hello tarekmadkour.
I have same problem and i’m using the same account I used last week. But for authenticate in orchestrator i need reset my password. Does it have anything to do with it?

1 Like

Yes @jomorais. You should be using the old password that you had before migration.

3 Likes

my account is old one -migrated from community orchestrator.

1 Like

Yes @tarekmadkour, now is working. Thanks for support.

3 Likes

@tarekmadkour can you help me please.

1 Like

Hi @lndiop

For standalone installation of Orchestrator the API did not change. See here for the docs :slight_smile:
https://orchestrator.uipath.com/v2019-fastTrack/reference

1 Like

We’ve already install our Orchestrator and we use it normally but i cannot use API for authenticate. Do we have to enable parameter ou activate something?’

2 Likes

If you have an account created before last week you have to use the credentials that you used before the update. Link is different, now is https://platform.uipath.com/KamalEnvironment/KamalEnvironment/api/Account/Authenticate
in kamal environment use the name of your service in orchestrator.

1 Like

We have our own orchestrator with entreprise license but when i use this url http://xxxxx.com/api/Account/Authenticate i have a 404 error .

if i understand , we have to use https://xxxx.com/nameofourservice/nameofourservice/api/Account/Authenticate ? ,

1 Like

@lndiop

Can you access the API definitions by navigating to an URL that looks like this:
http://platform.uipath.com/swagger/ui/index
but with platform.uipath.com replaced by your Orchestrator URL?

Leaving you with:
http://your.Orchestrator.Instance/swagger/ui/index

3 Likes

What can I do to make the Node-Red integration work again? What information should I put in these fields?

image

1 Like

@marcelojrfarias - you should use the exact same username and password you used two weeks ago before the migration to cloud started.

2 Likes

Hello @loginerror ,
Yes i can access via SWAGGER but when i call Api directly in my html page. I’ve a 404 error.

1 Like