UiPath Orchestrator APIs not working since Cloud Platform Release

HI Marcelo,

I’m sorry that you are facing this issue. I just tried the forgot password thrice and tried updating the new password from the password reset email and it seems to be working for me. Hence asking the follow up questions.

  • Were you able to get the reset password email to your email address, when you enter your email address in Forgot Password?
  • Were you able to reset password from the link in your email and update the password?
  • If you were able to update the password, you were not able to login using this updated password?
  • Could you retry these steps again and see if you were able to reset the password now?

Thanks, and sorry for asking you to do these steps again.

3 Likes

Hi all,

There’s a practical example using the new authentication method at https://hackernoon.com/robotic-process-automation-and-low-code-a-practical-tutorial-on-integrating-uipath-with-joget-b646bd2b96f2 in case you still have trouble authenticating.

Hope this helps!

4 Likes

Hello, @Vijay_Rajasekharuni!

I have been able to reset my password a few times without any problems. And the modifications take effect when I try to access the web portal, I always need to use the new password.

But even updating the password on Node-Red, I can not successfully create my jobs.

I’ve tried some settings, but to no avail.

First attempt:
image

Second attempt:
image

Third attempt:
image

1 Like

Hi Marcelo,

You are trying to use the Basic Authentication here when you are trying the username and password. This method doesn’t work in the Cloud Orchestrator. Please take a look at the steps provided in https://orchestrator.uipath.com/v2019/reference#consuming-cloud-api to generate the refresh_token and access_token. You can create a HTTP request by adding Authentication and TenantName headers as mentioned in the document to make calls to Cloud Orchestrator.

3 Likes

Hi Marcelo,

This current method of authentication will work until July 15 on Cloud Orchestrator, after which only OAuth 2.0 will be supported. To make it work for now, change your URL to https://platform.uipath.com//.

I’ll be updating the Node-RED connector to support the new authentication this weekend and will respond back here once it’s done.

4 Likes

Thanks for your help!

I changed the url to <https://platform.uipath.com/ 2 /> as requested (I tried https://platform.uipath.com/2/ too), but it did not work. Now I get a message “Could not find a process named [my_process_name] in [my_environment]”

I’m waiting for your update.

1 Like

Hi @marcelojrfarias

Could you check out this post of me for more reference on how to use the new Cloud API?

It contains a zipped project that will generate you all the necessary things. It is basically a project version of the guide from here:
https://orchestrator.uipath.com/v2019/reference#consuming-cloud-api

3 Likes

When I try to access the provided URL (https://platform.uipath.com/swagger/ui/index#/), it gives Account Not Found error. When I access the URL, it prompts login and then gives the error. However, if I just login to the account, there aren’t any such issues.

Could you kindly advise on this?

2 Likes

Hi @deepak.naidu

Please first navigate to your Orchestrator and then append this to the address:
/swagger/ui/index#/

Your link will look like so:
https://platform.uipath.com/yourCloudAccountName/yourOrchesteratorServicename/swagger/ui/index#/

3 Likes

@loginerror

Thanks, it works now.

2 Likes

It doesn’t work for me.
I’ve tried the oauth method with mobile:
https://platform.uipath.com/cloudrpa/api/getAccountsForCastGroupDefault
https://platform.uipath.com/cloudrpa/api/getAccountsForCastGroup

Or the by pasting the swagger link into my orchestrator

https://platform.uipath.com/CastGroup/CastGroupDefault/swagger/ui/index#/Account

I’ve tried multiple iterations (using my personal account name, email, removing default from default from CastGroupDefault, admin, empty

1 Like

hey guys, can someone please tell whether it’s a problem on my side or UIPath?
I spent 2 months on a project, the API is the only step missing in my whole process

hi @danielvianna @loginerror @deepak.naidu @kensho76

the uipath cloud platform have different ways to Authentication, go to the following link to do the authentication https://docs.uipath.com/orchestrator/v2019/reference#consuming-cloud-api

and the rest of the api are same https://docs.uipath.com/orchestrator/v2019/reference#about-odata-and-references

Happy Learning😊
Achal Sharma

4 Likes

@Achal_Sharma Achal do you have currently a project with working api that uses the api to trigger orchestrator?

Check here:

The project contains all you need. The 04. Get License.xaml is the sample API request to get license info from Orchestrator :slight_smile:

I will check loginerror, thank you!

I moved my request to the other post. I still have the same issue. It’s not a problem generating the keys and tokens but the actual authentication itself to activate orchestrator

Hi @KamalSaran,
How to find the tenancy name in the orchestrator?

Thanks.
Vashisht.

Hi @Vashisht

The service is the tenancy name in the orchestrator, if you are using enterprises orchestrator. If you are using community version orchestrator then use the follwing step:-
Community Version Orchestrator API

Cheers :slight_smile:

Regards
Achal Sharma

1 Like

Maybe it can be useful for someone.

I have started to use the Orchestrator API. I was facing the “Invalid credentials, failed to login” error despite of using the correct credentials (same I use log to platform.uipath.com/).

Aparently, at least it was my case, when I changed (weeks ago) the password because I had troubles to login, this was updated only for the platform but no for API (https://platform.uipath.com/api/account/authenticate).

I tried the old password and it worked!

As it occured to some people, I had problems to find find the Tenant Name. You can check it in “My Profile” (click on up-right corner (the orange circle) >> MyProfile)

Regards