UIPath on Server 2016 - Desktop has been disconnected while performing UI actions


#1

Scenario:

Scheduled automation running to control website, downloading attachments from it. Remote Desktop Connection Manager 2.7 used to connect to remote desktop running Windows Server 2016. Screen for the PC locked, screen on local machine open or locked.

Steps to reproduce:

Running the automation on a schedule, and maybe ½ way through it gives the error of “Desktop has been disconnected while performing UI actions.” When I go to unlock the remote computer, the site is open and awaiting the next file to work on.

Studio/Version: 2016.2.6274

Additional Notes:

Whether my local machine is in use, or my screen is locked this is now occurring each time I run this automation. It had been running fine before, and had this happening during the night while i was away. I have also gone in to group policy settings and regedit to make sure any type of setting related to timeouts that could impact the automation are set to keep the computer active.


#2

Hello.

If you are running the robot while connected to a virtual machine with Remote Desktop you might have problems if you are using Hardware Event UI interactions. RDC doesn’t generate the UI when the user has the window minimized. I’m not 100% sure but the same behavior can happen if the screen is locked. Can you do the changes specified in this article:

https://support.smartbear.com/testcomplete/docs/testing-with/running/via-rdp/in-minimized-window.html


#3

thanks for the reply. ive tried this. however i believe that another problem is still related to saving the attachments as well. 100% successfully clicking save on the dialog box seems impossible.

I will continue to operate and see if it breaks again.