UIPath not working with OpenJDK 11

What are the steps to get UIPath to work with my Java app that is using OpenJDK (x64)?

I have tried the community solutions but I am still unable to get UIExplorer / Studo to work correctly in a newly installed, clean Windows 10 Pro environment.

When I use UIExplorer to read my Java app, I am presented with this message:

Following the instructions, including a reboot, results in the same “Question” dialog.

  • Is UIPath compatible with OpenJDK 11?
  • Has ANYONE been able to get UIPath working with OpenJDK 11?
  • What specific steps are needed for UIPath to work with Java selectors when the Java app is using OpenJDK (x64) on Windows 10 21H1 64bit 8GB?
1 Like

had you seen this already?

The solution (from July 2020) did not work. Has anyone got OpenJDK 11 to work with UIPath?

1 Like


Hello Gary,
in the context of different tests I tried Java 16.0.2, which did not work, and Java 15.0.2, which works. In the UiPath documentation about the Java extension we can read that it is compatible with any version of JRE’s, from Java 3 to Java 15. So I tried also version 11.0.2 of the openJDK from the Java archive.

I got some warning messages, but everything worked fine. Detection of the window and the elements, recording and replay.

To your questions:

  • Is UIPath compatible with OpenJDK 11?
    After my simple test, I would say yes.
  • Has ANYONE been able to get UIPath working with OpenJDK 11?
    Yes, it worked for me, as far as I can say.
  • What specific steps are needed?
    I unpack openJDK 11.0.2, set the JAVA_HOME path to the bin directory and install the UiPath runtime plugin, that was all.
    My environment was the same as yours, Windows 10 21H1 x64 with UiPath Studio 21.8.

Best regards

Hi @grosner

Have you tried following the steps here: Extension for Java? Since you are using a version of Java higher than 11, the installer won’t help you, and you need to do some steps manually. First thing first: what type of Java app do you have? Is it a simple .jar file, an .exe, a .bat file, or a .jnlp (Java Web Start)? Depending on that, you can proceed in following the correct steps from the documentation above. I can also assist you in doing this, we can even have a call, if you want.

@StefanSchnell , in your case the bridge is loaded by agent injection, and that’s a method that doesn’t always work. Normally, the extension tries to communicate with the app, based on the fact that the dependencies are loaded; if that doesn’t work, then injection is used, which loads the dependencies from the same UiPath .nuget package that is used by the Studio at that moment.

1 Like


Hello Vlad,
thank you very much for your informative explanation, very helpful.
Best regards

1 Like

Thank you for the test and the confirmations.
Ultimately, to get UIPath to work with the OpenJDK SunAwt app:

  1. Populate c:\UiPath with:


  1. Add the following to the app’s .vmoptions file:

-classpath C:\UiPath\UiPathBridge.jar;C:\UiPath\UiPathJavaServiceProvider.jar

  1. Verify the application’s appname\jre\conf\accessibility.properties file contains:



  1. Update Studio (community edition) to use latest packages.
  2. Removed the global %userprofile%.accessibility.properties file.
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.