UiPath not auto-completing LINQ


This is quite annoying and affects many of my colleagues, the AsEnumerable suddenly is not auto-completing but works if run. The System.Data.DataSetExtensions is already in XAML files and auto-completion feature of UiPath is still not working. Please help, @lakshman @loginerror @Palaniyappan. Thank you in advance guys.

1 Like

@iamthejuan Can you show us an Example?

Here is the screenshot of what I’m seeing and the XAML file itself.

Test.xaml (3.9 KB)

@iamthejuan The AsEnumerable Method appears for me for the xaml file that you have provided :sweat_smile:, Since you have already included System.Data.DataSetExtensions, I don’t actually know what might be the cause of this problem. But have you tried restarting Studio and checked if it is able to appear?

I already did, BTW this is my current UiPath version.

1 Like

Try with stable version and restart your studio
Kindly check and let know whether you are able to see AsEnumerable after that

Cheers @iamthejuan

Hi @Palaniyappan,

I tried but issue is still persisting.

I could see working
Kindly re install the application and try once pls

Cheers @iamthejuan

1 Like

Ok, I’ll try re-installing UiPath. That’s my last resort but if it works why not. I’ll update the thread once done. Thank you @Palaniyappan.

I often encounter a blocked intellisense when working with LINQ statements. In simple case I just dictate the code and ignore the missing suggestions.

Otherwise, we do following:
bringing with comments the modelling into a state that it is compiling
closing UiPath studio
delete from project the directories .local and .settings
ensure XAML is referencing System.Linq, System.Linq.Expressions, System.Data.DatasetExtensions

open project/XAML again and do continue to work. I the majority of cases it was better working after these steps

1 Like

Hi @Palaniyappan,

I have tried reinstalling multiple times:

A. First re-installation approach:

  1. Uninstalled UiPath
  2. Restarted computer
  3. Reinstalled using the most recent version of UiPath installer
  4. Not working both for (preview and stable)

B. Second re-installation approach:

  1. Uninstalled UiPath
  2. Restarted computer
  3. Reinstalled using the old installer I have that previously works with LINQ which I downloaded last April.
  4. Not working both for (preview and stable)

Still the issue is not resolved.

Hi @ppr,

I am not sure what do you mean here,

but the rest I followed

but still it doesn’t work.

Hi @Palaniyappan,

By the way after installing using my old version of UiPath installer which I downloaded last April, it became worse because the members of DataTable are all not auto-completing even when pressing Ctrl + Space.

Hi @iamthejuan

The issue was spotted by one of our developers as well and the ticket was registered for a fix.

I will keep updating this topic when more information become available.


Thank you @loginerror

The issue is fixed in the the 20.10 version (the fix should already be available on the preview channel, or will be shortly).

It will only work on newly created projects though.

1 Like

Thank you for the update. It works now.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.