UiPath not able to save outlook attachments

email
outlook
activities

#21

Hi Christine,
I am directly accessing through IMAP. I am not going through Outlook.


#22

Hi Priyatham,

Not sure if IMAP is any different from Outlook, but my company actually have IT policies that wouldn’t allow bots saving attachment or sending emails. On another project I have seen people able to save attachments from internal emails and not from external source. Have you consulted with IT?


#23

Hi,

No, the attachments were perfectly fine, they were simply excel and csv files. However, the Item.Attachments.Any returned “False”, although the attachment can be downloaded manually. The Mail.Activities pack was the newest as far as I know.

I also noticed that when the same attachment is added to an entirely new mail and sent with a different From-address, the attachment is detected as usual by UiPath (I noticed some other people had similar observations on this thread). It seemed to me the attachments were often not detected from mails that had been sent automatically by certain applications, instead of being sent by actual humans (or addresses owned by humans). There was even a case, when the entire email could not be detected by UiPath, if it was sent from the automated function of a certain application. Sometimes automatically forwarding these emails to another address fixed the problem and sometimes it didn’t. Taking the attachment out of the email and resending it for example from my own email address fixed the problem, but this obviously cannot be used as a solution.

Is it possible there are some unseen security functions in gmail/outlook or the Uipath Imap mail activities that could be the cause of this problem? It is almost like the activity cannot just “see” the attachments although it finds the email itself normally.

Best regards,
R


#24

I have the same scenario. As a workaround, I setup a outlook rule, to forward the same email to itself and access it through IMAP(uipath). The only downside is, If the outlook rule fails, then bot would fail too.


#25

Hi,

Been experiencing the same problem, does anybody solve this issue yet?

Thank you.


#26

Can you share more details please?


#27

Hi all (and @Gabriel_Tatu),

I ran into the same kind of problems as you guys. As I have been working with integration in a more raw format previously, I suspected that it is the structure of the mail itself.

The problem might not be evident when looking at the email in a Mail client (like Outlook or so), but you can see it in the mail source .

I tried sending the same email (body, subject and attachment) in three different ways:

  1. Using Outlook - works!
  2. Using Mail on OS X - doesn’t work!
  3. Using Webmail - works!

All on the same email account and same mail server.

Looking at the raw message I see that the three clients produces different attachement lines

  1. X-MS-Has-Attach: yes
    Content-Type: application/pdf; name=“CQ_123.pdf”
    Content-Description: CQ_123.pdf
    Content-Disposition: attachment; filename=“CQ_123.pdf”; size=18983;
    creation-date=“Tue, 09 Oct 2018 17:39:16 GMT”;
    modification-date=“Tue, 09 Oct 2018 17:39:16 GMT”
    Content-ID: BE574B3115E3134AB59899E31C7B6FCF@EURPRD10.PROD.OUTLOOK.COM
    Content-Transfer-Encoding: base64

  2. Content-Disposition: inline;
    filename=CQ_123.pdf
    Content-Type: application/pdf;
    x-unix-mode=0644;
    name=“CQ_123.pdf”
    Content-Transfer-Encoding: base64

  3. Content-Type: application/pdf; name=“CQ_123.pdf”
    Content-Disposition: attachment; filename=“CQ_123.pdf”
    Content-Transfer-Encoding: base64

So it seems that UiPath are unable to process emails which has attachments that are sent “inline” as OS X does, while the mail clients are perfectly capable of that. We could argue that OS X is sending “broken” emails, but I guess there could be other cases.

Maybe UiPath should look into this?


#28

I have the same problem.
I can read the subject of mails, but not the body, headers or attachments (and maybe more but these are the four I have tried so far. I came across several topics with these kind of problems (body not being read, attachment not being saved while they definitely exists).

Anyone with a working solution yet?