UiPath - Microsoft Word automation struggle

uiautomation
word

#1

I was using UiPath with Microsoft Office 2013, and everything was working well. I was making workflows for Word to quicken my tasks. Yet after recent upgrade to Microsoft Office 2016, i was unable to run new sequences due to following errors:

Message: Unable to cast COM object of type ‘Microsoft.Office.Interop.Word.ApplicationClass’ to interface type ‘Microsoft.Office.Interop.Word.Application’. This operation failed because the QueryInterface call on the COM component for the interface with IID ‘{00020970-0000-0000-C000-000000000046}’ failed due to the following error: Interfejs niezarejestrowany.* (Exception from HRESULT: 0x80040155).

*Interface Not Registered

OR

Error opening document, make sure Word application is installed

I was trying to recreate old automations (assuming previous ones won’t work on Word 2016) when the errors occured.
To solve the issue, I tried to repair/reinstall Office, reinstall UiPath, or clean registry - neither of those worked.

Please tell me how can i solve this issue?
I will appreciate any help.