UiPath Level 3 lesson 1 UiDemo - Need help!

I am unable to successfully run the UiDemo login sequence. My problem is not being able to work with credentials properly. Need help!

1 Like

Hi @arbaaz

Welcome to the community!! :smiley:

Looks like you have a problem with credentials. What is the exact problem you are facing? Bit more explanation will help us understand what the issue is :slight_smile:

Thank you for replying.

As instructed in the walkthrough pdf, i created the workflow. In sequence, i do & get the following:

When i test execute the above workflow sequence, i get this prompt locally from the windows credential manager, which is fine and works well, but in the walkthrough it is recommended to get credentials from orchestrator, which i am not able to, as the workflow only works with local window credential manager. So i press cancel and get the following.

That’s a good detailed explanation… I understand the problem.

So If I’m to explain about How GetAppCredentials.xaml work, its like this…

First of all, it checks whether it can retrieve the credentials from the Orchestrator. however, If it is unable to get the credentials from the orchestrator, it switches back to the Windows authentication and looks for credentials there in your local machine. If the local machine do not have credentials under the credential name, it prompts the message for you to enter the credentials just like what you have in your screenshot. Once the you enter the credentials the first time, it gets saved in your local windows authentication and will not ask for credentials from you again.

So, why does it switch to windows authentication when you want to get credentials from the orchestrator? Few things can affect this.

  1. You do not have the credential asset defined in the orchestrator
  2. Your config file is not configured to have the correct orchestrator asset name
  3. Your local robot is not connected with the orchestrator.

Make sure these are done properly.

Let know the progress…

Thanks. I have created the necessary credential asset and my local robot is connected to the orchestrator. I think something is wrong with the config file. How to see if i have the correct orchestrator asset name, and if i don’t then what to do?

cool… So go to orchestrator, and check the credential asset name.

Lets say for example, your orchestrator credential asset name is UiDemo_Credential

Now, get to your config file, and under Settings sheet, check whether your have “UiDemo_Credetial” mentioned under value column. And you should have a value for the Name column as well. Name column is the unique identifier to refer to the name you have under value column.

Additionally, Go to InitAllApplications.xaml and locate the invoke workflow activity that calls UiDemo_Login.xaml. There, we pass an argument from the config file which describes the credential name… Something like this

In there, just make sure you specify the identifier you specified under the Name column of the config file that is used to identify the credential asset.

This should work for you…

If it works, please also make sure to mark my answer as the solution too :slight_smile:

Something seems wrong. I am getting validation errors.

Although i was able to test run the UiDemo login sequence properly by using the Get Credential activity (Orchestrator activity in studio). But somehow i am still not able to get the UiDemo login workflow to run properly by using Getappcredential.xaml

Can you share your solution as a zip file? I can have a look

Hello @arbaaz
make sure you check variable and argument name like no space at the end of variable or when you get from in_Config(“UiDemoCredential”)
Most of the time this type of mistake happend.
I already do this of mistake earlier:stuck_out_tongue: .

Happy Automation

Thank you. But i am not able to upload attachments as of now. I am getting this.

Also unfortunately i have run into another problem.

Earlier my UiDemo_Login workflow was running well by using windows credential manager or Get credential (orchestrator activity). But now my workflow gives me this error no matter what.

Can you email me the solution… I will send the email address through a personal message here in the forum

Hi @arbaaz

I have few questions here…

  1. IN your Config file, you mentioned that your orchestrator credential name is UIDemoLogin

  1. In your UiDemo_Login.xaml, when calling GetAppCredential, you have hard coded the name as “TestRobot-Credential” which is not equal to what you have in the config.

    This should come from the config file.

  2. Additionally, regarding the UI element error, I do not see where you have specified the open application activity to open the UIDemo application. You only have the attach window in the login.xaml. That error is coming may be because UIDemo app is not open in the background.

You will need to correct those to get it to work bro.

Refer the below two xaml files for the correct flow of the UIDemo login
UiDemo_Login.xaml (9.5 KB)
InitAllApplications.xaml (7.6 KB)

Let know whether it helps!!


Thank you. With your advice i was able to solve most of the problems. Here is what i did:

Also i used to run UiDemo with administrator privileges which also caused problems, but when i ran UiDemo normally it worked fine.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.