UiPath Jenkins Integration issue

Hello Everyone,

We are integrating UiPAth + Jenkins. Facing an issue while executing Powershell script to execute PACK command.
image

Having the same problem …

Has anyone got success in running the UiPath from Jenkins? If yes please share the steps to configure.

I have installed the UiPath Pulgin and tried to follow this:


but it did not worked.

2 Likes

Hi,
The Jenkins Plugin available on Go! is in a beta state and not officially supported or maintained. Atm we are working on a product version of it, available with our April release. This new version will be able to pack and deploy workflows/test cases and run test cases on Orchestrator.
Meanwhile, I am happy to assist you with the issues you are facing with the old version. Could you provide some further details here, or if you prefer to join a zoom call on it, pls drop me an email on thomas.stocker@uipath.com

1 Like

Hi @ThomasStocker,
I have downloaded the zip file. I extracted it. It has the hpi file. Can you guide me that how to use it.

Thank you
Balamurugan.S

Hi balupad14,
to install a .hpi file on Jenkins pls follow these steps:
Manage Jenkins -> Manage Plugins -> (Tab) Advanced -> Upload Plugin (Choose File)

After installation, you will have 1 build step available called ‘UiPath Pack’ and 1 post-build step called ‘UiPath Deploy’

For details on the usage pls have a look at:

If there any further questions, pls let me know.

BR
Thomas

Hi Thomas,

I am facing the same issue. Any help will be appreciated.

Regards,
Sachin

Hi Sachin9s, as mentioned, lets setup a zoom call to discuss.

Hi Thomas,

I re-installed Enterprise version and issue got corrected.
Thanks for replying.

Hello Thomas,

I was wondering about the latest news on this topic. Did the official plug-in release happen? Or Does UiPath plan to make some tutorials or some more specific documents about it? We are also new at Jenkins-Uipath integration and could really use some help.

Is there anyone who has successfully run test on Jenkins?

I am having issues on how to setup the user account.

Hi @Glenn_V, to set up your username-password credentials with Jenkins, you’ll have to follow the steps outlined here.

Thank you for the response. I have tried this but my orchestrator account is on gmail, so it has no password. Would you know how to configure that?

Hello Alvin,
we are are using Orchestrator 2020.4.1 enterprise edition, while configuring we gave used general credentials like admin for Orchestrator. And now when integrating uipath with jenkins, at post build-task : uipath run test, we are using On-premise orchestrator option and created credentials for "admin" user in jenkins and using the same. but getting the below exception when building project from jenkins.
{“message”:“The user ‘adm***in’ is locked out.”,“errorCode”:1000,“resourceIds”:null}

Hi Glenn,

You’ll have to create a local account for Jenkins in this case, as we do not support authorization via the Google Integration.

Hi Prabhumkpeak,

I’m not sure if this happened due to something on the Jenkins side, but a lock-out normally occurs when somebody tries to log in too many times with that account using the wrong password.

This is temporary though, so try logging in from the UI with that user again, ensure that it works over there with those credentials, then re-use them in Jenkins.

Hello Alvin,

I could able to login Orchestrator UI using same credentials, only in Jenkins i am facing this issue.

Regards,
Prabhu