UIPATH isn't displaying the correct value from the same Excel file

I use UIPATH to create a simple read cell data from Excel file. I created a message box to display the read cell data to confirm it is picking up from the right cell. Once validated, I change some of the values in the cell and run UIPATH again. For some reasons, UIPATH is displaying the old value instead of the new one from the same Excel file.
I tried to uninstall and reinstall UIPATH and it seemed to work yesterday but not today.

My co-worker try the same but not seeing the same situation on her machine/UIPATH.
Has anyone see this issue?


Welcome back to the uipath community.

Once check variables whether you initialized any default values to it or not. If yes then delete it and try once.

There is no default values set initially. The weird thing was my coworker isn’t seeing the same issue with the use of the same json file. Basically, I zipped up and sent over to her.

So you’re opening excel, reading value from excel, updating excel, then reading value from excel again?

If the above is true, it sounds like you are not saving excel. Add a ‘save workbook’ activity after updating excel and before reading the updated value and it should fix it. Better yet, don’t use the read cell activity the second time, just make all changes to the variable itself so you only have to use the read cell activity one time

The Excel file is closed before I run the UIPATH to read the file. I do save and close the file prior running UIPATH too. Will try to add save workbook activity and see if it makes any difference.

Are you using a write cell or write range activity to update the excel before you save and close?