UiPath is not able to communicate with Edge browser in Private window

I already added an extension in Microsoft Edge & enable the Allow access in the private window but still it doesn’t work.

Hi @Mozammil

Hope it helps!!




Hi @Mozammil

If you are using use application\browser activity then in the properties panel you have the Incognito\private window option, check the option and it will open the webpage in Incognito window.

If you are using open browser activity which is classic activity, in the properties there is a private option check that and it will open the webpage in incognito window.

Hope it helps!!

Hi @Mozammil ,
Can you share your image about error

UiPath.Core.BrowserOperationException: Cannot communicate with the browser, please check the UiPath extension. —> System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x80040234 at UiPath.UiSystemClass.StartBrowser(String bstrSelector, String bstrURL, String bstrArguments, UiBrowserName browserType, Int32 timeoutMs, UiBrowserFlags browserFlags)
at UiPath.Core.Browser.Open(String url, CommMethod startBrowserMechanism, Boolean privateSession, Boolean headlessSession, Boolean defaultSession, String cmdLineArgs, Int32 timeoutMs)
— End of inner exception stack trace —
at System.Activities.Statements.Throw.Execute(CodeActivityContext context)
at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Hi @Mozammil ,
You can try
-Close Edge
-Open UiPath Studio
-Go to Home–> tools → choose Edge

If it already install, you can uninstall then install again
Allow turn on extension
Or try with other browser
Hope it work

@Nguyen_Van_Luong1 After trying every possible scenario I came to the forum.
Re-Installing the UiPath
Updating the .net components
Updating the browser

Everything possible thing I did from my end

Already did this for running the project in private

Other browser eg: Chrome, Firefox… have same error?

Have you selected the option all to use private window in edge browser. If not follow the below steps.
=> Open the edge browser
=> Click on 3 dots at top right.
=> Select the Extensions → open Manage extensions.
=> You find the UiPath extension there → Click on details
=> A window open check the Allow in Private option. This will allows to do the automation in private window.

Check the below image for better understanding.

Hope it helps!!

This is a known issue after updating to Edge 115

UiPath has reported the issue to Microsoft MV3 browser extensions are broken when starting Edge v115 with InPrivate option - News / Product News - UiPath Community Forum