Uipath Having trouble filling in forums

Hi Guys, I want to fill in an Multiple choice Question in a Form. The one to fill in depends on a filled in name in Excel. So it’s about a person that has a supervisor, now i want to fill in the supervisor but the question needs to be Multiple choice.
So Uipath reads out of the Excel sheet who the Supervisor is and needs to push the right button in the form.

From here Uipath reads the Supervisor “Leidinggevende”

please share the selector for the Koen button

I though i could replace the ‘Koen Kranenberg’ by my variable Leidinggevende. But you can say I am new to Uipath so don’t know for real how it works

You can do that. Perform a write line of the selector after you have passed it the Leidnggevende variable so that you can compare it against the hard coded Koen selector.

that may help you troubleshoot the issue

can you give me the code for the selector?

Only you can provide that. Use UiExplorer to provide the exact selector required to click the Koen checkbox.

Then perform a write line before the click activity to ensure the selector you are passing exactly matches what the UiExplorer is telling you it should be

The thing is, if the next row has the supervisor Marc he needs to click on Marc. Thats the missing thing. So i can make the selector for Koen but if the Supervisor isn’t Koen anymore it still hits the Koen button in the Form.

You are passing it your supervisor name as a variable so that should not be a problem.

when the supervisor changes, the variable is updated and passed to the selector. your logic is right but you need to troubleshoot the process as I explained using write lines.

Okay I get it. But don’t know how to put the variable in the selector. I tried with some examples on the forum but de selector isn’t valid every time.

<webctrl aaname='" + YourVariable + "' parentid='field22462' tag='LABEL' />

I did but it isn’t valided

Ok I see your issue…

Do not introduce the variable to your selector in the Selector Editor pane.

Make the edit to the selector here in the expression editor:

image

Okay I did and it’s now like this.
“”

Still isn’t working see the image what it is saying.

You have spaces around Koen Kranenberg.

Try this: <webctrl aaname=’" + Trim(YourVariable) + "’ parentid=‘field22462’ tag=‘LABEL’ />

1 Like

Thank you it is working now!! the problem was not the Trim, I had spaces between ’ " + MyVariable + " ’
I did ‘" + MyVariable + "’ and it worked. Really thankfull!