UIpath Executor has stopped working

Is there any fix/ update as we moved our project developed on Version 2018.2.3 to Version 2018.3.2.

We are also facing the same error.

In this project we download the excel file from web QLS(Query logging system) and process that case in SAP and upload back that Excel file(11 KB) file to web CRM application only.

@loginerror @Abu

Awaiting reply.

Regards
HJ

Good day @Harshit_jain

Two questions,

  1. Have you tried using the delay workaround?
  2. Have you tried re-installing the excel application or using a different version on the robot machine? What version of Excel are you currently using?

Hey @Abu,

Thank for the suggestion.

It was already running on Version 2018.2.3, As we got a new installer 2018.3.2. We have to move it to production with the new version.

Also we are now running it on VM with MS Office 2016, where in local it was deployed with MS-Office 2010.

Hi all,

I am also facing the same error Uipath.executor has stopped working and we are not able to identify conclusively the reason behind the error. We are using a lot of excel files during the execution of the process which involves invoking multiple workflows, but after each workflow we are using the Kill process activity to close all the open excel files so that they won’t hinder the process. But inspite of this , we are facing the UiPath.executor error. Can someone please suggest a solution for this.Eagerly waiting for the reply.

Thanks,
Arjun

1 Like

Hello Arjun,

Could you please check the version which you are using.

Also check for the dependencies.

Regards
Harshit

Hello Arjun,

Have you solved this problem? I am facing the similar issue with yours. If you know the solution, please kindly share with us. Thank you!

1 Like

This can happen when upgrade package to upper version. Like Core Activity and Excel activity.
I have faced this in the time of migration from development to UAT environment where we had different activity packages. Try downgrading it.

If this happens particular with one excel file thrn go for the Invoke code.

1 Like

Hi All,

I’m also facing the same issue. “UiPath.Executor has stopped working” and it’s occur in different process/sites/application in my project.
Sometimes it occur while processing with Internet Explorer, sometime with MS Word and sometimes in MS Excel.
I’m also using delay, as a matter of fact it running now 5x slower than manual process but still having this issue.
Any idea why is it occuring? By the way I’m running it with version 2018.4.5

TIA!

1 Like

Any fix for this?

what is your particular case, that error was solved in previous versions

This error appears to occur when dealing with Excel files with too many records. In my case, the error occurs when trying to write a DataTable with 57k of records using the WorkBook Write Range, which causes the memory to collapse and generate an exception of type System.OutOfMemoryException

The solution for me was to use the Write Range activity of Excel Application Scope, however on some occasions the problem appears through the DataTable. I have read that this problem is oriented towards the memory consumption of the machine where the process is executed and its architecture (if it is 32 Bits or 64 Bits) if it is 64 Bits when the memory consumption exceeds 50 % of available memory, then the process generates exception. If the machine is 32 bits you should not present this error. Downgrade the packages did not work for me.

Error-SystemOutOfMemory

Untitled
Hi All,
I am also facing this error can any one have solution
plz help me
thanq

Hello,

I have had the same problem (for more details see: Uipath robot executor has stopped working during Excel Application Scope ).

Any idea how to solve it, please?

Thank you very much in advance.
Regards
Luboš

Hello,

I had the same problem and solved it by downgrading the UiPath.Excel.Activities package (via package manager) to the pre-latest version. At the moment of this comment latest v.2.8.5 and it worked with v.2.7.2

Best of luck.
JMartinez

1 Like

Hi @loginerror I am also getting this type of error at a certain point where validation and accounting related activities included In ORACLE…

on this screen of the oracle, I am getting the same error…

Hi @Mohsin_Inamdar

What is your Studio/UI Automation package version? Does upgrading the activity package help you solve this issue?

Also, are you using our Java addon (it can be installed in the settings)?

Hello
I’m also getting same problem while running the bot from studio the bot gone stopped and getting above error .
please any one help me,I’m using latest community version :2020.10.2

have you solved the issue?

@Angelica_Lubao
Still getting same issue :worried:

Does an update of the Database activity package to the latest version help here?